(4.1) and Gallery 2.0.9 installation error. - Uploading of specified file has failed.

  • Affected App
    WoltLab Suite Gallery

    The steps I've done in xampp on localhost were the following.


    1) Installed 4.1 RC1 fresh, installation went fine.
    2) Installed latest woltlab Blog 2.0.9, installation went fine.
    3) Attempted installing of Gallery 2.0.3. received error. "Uploading of specified file has failed."


    I unzipped a few times (\upload\install\packages)to retrieve the gallery package archive from the latest "Set Up" archive from "My Downloads" under "My Account", WoltLab Community Gallery 2.0.3 (Setup). Selected it as in screen shot below. @Alexander Ebert




    I hit submit, and then get the following error.


    Edited once, last by Smooey ().

  • Yes, the same happened to me. I experienced the same error with a local installation (Xampp) and with two different hosts (one shared account and one VPS). This error also seems to occur if installing Gallery first (successfully) and trying to install Blog after that.

  • I got the same error message attempting install Calendar 2.0.2. It appears to only allow one woltlab plugin to be installed, the others then give errors trying to install them. This must be a WCF bug, not gallery bug. Please move to proper bug section if needed.

    Edited once, last by Smooey ().

    • Official Post

    Please use the update package, the setup package is for a standalone installation only.

    Alexander Ebert
    Senior Developer WoltLab® GmbH

  • Please use the update package, the setup package is for a standalone installation only.

    Okay, will do. But it did work before though, doing blog package extracted from the setup package. It's what I've always used.


    Extract: gallery2.0.3.zip
    creates upload folder, then extract WCFSetup.tar.gz archive, gives WCFSetup.tar then extract that, then it gives install & setup folders, then in the install folder, go to packages folder, to get the archive for "com.woltlab.gallery.tar"


    Edit, I've downloaded the gallery update package, same error.


    This should be now fixed, actually was never broken. On xampp, I didn't have proper upload size settings set. Hence calendar and gallery packages weren't installing, but only blog was. I added this in root / htdocs htaccess file.. and all plugins installed fine via tar archives.


    @Alexander Ebert

    Code
    php_value post_max_size 70M
    php_value upload_max_filesize 64M
    php_value max_execution_time 60
    php_value max_input_time 180
    php_value memory_limit 256M

    Edited 8 times, last by Smooey ().

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!