RSS Feed sometimes won't let you add one

  • Affected App
    WoltLab Suite Forum

    There is something wrong with adding RSS Feeds.

    I set-up a new install of Beta 2 today and managed at first to add an RSS Feed pulling feeds in from the news forum located here. Later I deleted that feed and all feed posts displayed on a forum for it pulled, then was able to add the feed back again and it grabbed the feed posts once more. No problem, worked fine!

    Now all of a sudden I tried to add a second Feed pulling content from your blog and it won't let me add the 2nd feed and keeps showing me a "red box" and refuses to add the feed. So I went and deleted the 1st feed I added before (deleting it for 2nd time) and removed all the posts for it on a forum again. But this time around I cannot add that feed back and get same error with that also using exact same details filling in feed fields - that I used before and worked.

    So don't know what it is, as at first it let me add a feed and worked pulling content into a board. Now it does same as it has before when installing BB 4.1. Did same then and suddenly just stops letting you add any feeds. And if you try and edit the one already added when it worked (it will show you same error message bar) for it refusing to let you edit the feed

    Edited 4 times, last by Macondiana (December 27, 2014 at 7:33 PM).

  • There isn't any field marked to looked at not being filled in right. No field is highlighted at all. And once this starts then it impossible afterwards to add any feeds. It seems to break the function for good then.

    This is the feed I added at first which worked no problem after first installing the board. But now using same details it won't save the feed anymore.

    Edited once, last by Macondiana (December 27, 2014 at 7:53 PM).

  • OK. I'll send you an email in a minute with FTP and Forum login details for my admin account

    Just a note. Even though you will see an htaccess file being used with the Burning Board now and ReWrite enabled. I wasn't before when RSS feed was not working. I only uploaded that htaccess file last hour and enabled rewrites to try it will that also ans still fails. So have tried both ways. Without rewrites enabled and no htaccess file uploaded - and also with it enabled

    Edited 2 times, last by Macondiana (December 28, 2014 at 1:12 AM).

  • @GTB I have been pretty busy in the past few days, looking forward to check it today.

    Edit: Okay, I got it, there is something wrong with label groups which are (1) set to force a selection and (2) not assigned for the selected forum. The system incorrectly recognizes, that the label group is not associated with the forum and incorrectly assumes the user failed to select a label. Since there is no applicable group, no further selection is shown and you end up with an "empty" error message. Moving this to the bug section.

  • So if I remove (delete) all the labels and its group for now used on my forum would RSS Feed then work 0k again

    EDIT: Yes it does, I just deleted labels and group and now can add a feed again

    Edited once, last by Macondiana (December 29, 2014 at 9:19 PM).

  • Most likely nothing but seeing as you said you patched my forum. I created a label group again and added two labels. When I select the label group to put labels with I'm seeing two blank spaces in drop-down box before label list is seen.

    Is that correct, look at image below and I put two arrows pointing to were I mean. I would have expected the label mist to be shown right below "No Selection", not 3 lines down with two above it being empty spaces

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!