Geschriebenes im Editor zeilenweise nicht sichtbar

  • Hallo,


    ich habe folgendes Phänomen festgestellt bei mir...
    Ich schreibe am Handy eine Antwort auf einen Beitrag. Irgendwann fängt es an als würde es automatisch in weiß geschrieben werden was ich eintippe. Schreibe ich weiter wird irgendwann sichtbar was ich schon geschrieben habe...


    Handy: iPhone 5s
    iOS: 7.1


    Hatte das schonmal jemand?

  • Ja, passiert mir auch.
    iPhone 5 und iPad 2, iOS 7.x


    Da der Editor aber seine Macken mit MobileDevices hat, habe ich mich bisher nicht beschwert :)


    Auch bekannte Fehler:
    springt beim löschen (backspace) oder Anreden von Usern mit @ in andere Zeile oder Zeilenanfang.

    Viele Grüße
    Carsten :thumbup:

    • Official Post

    Ich habe es nun selbst mal mit iOS 7.1 ausprobiert und das Problem scheint erst aufzutreten, wenn man in der letzten Zeile angelangt ist. Die Eingabe bleibt unsichtbar, bis man in die nächste Zeile rutscht. Interessanter Weise wird der Inhalt auch sichtbar, wenn man Enter drückt, anschließend kann man den Zeilenumbruch mit Backspace wieder löschen und der Inhalt bleibt sichtbar.


    Eine Lösung für dieses Problem kann ich gegenwärtig allerdings nicht anbieten.

  • Alles klar. So intensiv habe ich es dann nicht getestet, aber es wird wohl bei mir gleich sein, da ich auch 7.1 habe.


    Es ist ein bisschen blöd, aber auch kein Weltuntergang jetzt :)

  • das gleiche problem gibt es bei uns seit kurzem auch.


    Hoffe auf einen schnellen Bugfix.

  • WCF 2.1 verwendet einen anderen Editor - dann erledigt sich das Problem hoffentlich.

    "A life is like a garden. Perfect moments can be had, but not preserved, except in memory. LLAP" — Leonard Nimoy

  • bis das kommt geht aber noch einige Zeit drauf. Zu meinem übel verwenden 90% meiner User IOS 7 und den Safari Browser das ist eine kleine Katastrophe

  • Das sehe ich auch so. Beiträge unter iOS 7 zu schreiben ist eine Zumutung. Vielleicht ist eine zeitnahe Lösung doch möglich. Auch die automatische Großschreibung am Satzanfang funktioniert bei dem Editor nicht...

  • Vielleicht ist eine zeitnahe Lösung doch möglich.


    Unwahrscheinlich, da WoltLab keine eigenen Anpassungen am CKEditor vornehmen will - dafür ist der Aufwand zu hoch. Man hatte sich ja extra für einen hochgelobten Editor entschieden, weil man genau solche Probleme umgehen wollte.

    "A life is like a garden. Perfect moments can be had, but not preserved, except in memory. LLAP" — Leonard Nimoy

    • Official Post

    Auch die automatische Großschreibung am Satzanfang funktioniert bei dem Editor nicht...


    Das fällt aber in den Verantwortungsbereich des Browsers, der Editor basiert (wie alle WYSIWYG-Editoren) auf dem sogenannten "Design-Modus" des jeweiligen Browsers. Man editiert dabei de facto direkt das HTML an dieser Stelle und Funktionen wie die Großschreibung am Satzanfang ist eine Funktion von Safari. Wenn dies im Editor nicht funktioniert, dann ist das ein Versagen des Browsers und eine Behebung liegt außerhalb unserer Möglichkeiten.


    Generell ist das Problem beim CKEditor, dass er in sich geschlossen ist und bis auf wenige Ausnahmen keine Änderungen von außen erlaubt. Wie @Netzwerg korrekt angemerkt hat, erlaubt Redactor (der neue Editor ab WCF 2.1) durch Plugins die gesamte Funktionsweise nahezu beliebig anzupassen. Dadurch habe ich auch die Möglichkeit, Probleme selbstständig zu lösen ohne die Update-Fähigkeit zu verlieren. Gerade die Änderung der Originaldateien wie bei WCF 1.x (TinyMCE) war ein fundamentaler Fehler.

  • Kleiner Tipp meinerseits um diesen Fehler etwas zu umgehen: Auf den Button "Quellcode" oder dem Textfenster klicken und dann mit dieser Formatierung weiterschreiben. Auf diese Weise kann man zumindest seine Ausführungen zuende bringen ;)

  • Der Fehler wurde laut Label in WCF 2.1.0 Beta 1 behoben. Oder was genau meinst du? Für das 4.0 wird es keine Lösung mehr geben.

    www.cls-design.com
    Alle Stile jetzt auch in limitierter Stückzahl für WBB 4.1 (ノ´ヮ´)ノ*:・゚✧

  • Einen kleinen Workaround haben wir gefunden.
    Man kann den Browser "Atomic Web" nutzen und muss lediglich eine Einstellung anpassen
    "identify browser as" umstellen auf "safari desktop" und schon kann man lange Texte eingeben ohne das diese verschwinden