Smalltalk - Labern, reden, diskutieren...

  • In unserem Forum häufen sich aktuell Spam-Beitrag. Die neue registrierten User schreiben 5 belanglose Beiträge als Antworten in verschiedenen Themen. Nach ca. 5 Tage wird dann der sechste Beitrag verfasst mit einem Werbelink.
    Schaut man sich die verlinkten Homepage genauer an, dann gehören sie immer:

    Global Commerce Media, LLC

    42 Broadway Suite 12-432

    New York, NY 10004

    USA

    Telefon: +1 505-387-3649

    E-Mail: info@globalcommercemedia.com


    mit Inhaber Jannik Lindner Online Marketing (https://www.jannik-lindner.de/)

    Gibt es weitere betroffene Forenbetreiber?

  • Installier dir doch ein Ubuntu in einer Virtual Box und probiers mal stumpf aus. Wenns klappt, wiederholst du es auf dem Server.

    Milestones:

    • 18.02.2022 19:14 CET: Erste PWA installiert (und es war ausgerechnet YouTube Music)
  • Ich hab bei Vodafone immer noch Gigabit für 19,99. Dank jährlichem Anruf ändert sich da nie was dran, lol.

    Meine Beiträge stellen - sofern nicht ausdrücklich anders gekennzeichnet - ausschließlich meine subjektive und aus Erfahrung und / oder Reflexion gewonnene Meinung dar und sind nicht als Fakten zu verstehen. Meinungen sind persönliche Ansichten und benötigen keine Belege. In Deutschland gilt nach Artikel 5 des Grundgesetzes Meinungsfreiheit. Meine Beiträge stellen keine Rechtsberatung dar, hierzu bin ich nicht befugt.

  • Vodafone hat hier in der Region ständig Ausfälle.

    Und deswegen würde ich nie zu denen wechseln.


    Aber nen Gigabit für 20 Euro ist schon günstig. :)

    • Official Post

    Alexander Ebert kleine Frage zwischendurch ohne große Relevanz: Spricht etwas groß dagegen mit WSC 5.4 PHP 7.1 oder 7.2 oder direkt 7.3 mindestens vorauszusetzen?

    Die Mindestvoraussetzungen für WSC 5.4 lauten:

    • PHP 7.2.24
    • MySQL 5.7.31 / 8.0.19 oder MariaDB 10.1.44


    PHP 7.3 ist leider noch nicht überall verfügbar, aber bietet auch nicht wirklich irgendetwas spannendes. Die nächste interessante Version ist PHP 7.4, aber deren Verbreitung ist leider noch nicht ausreichend.

  • Ich habe bisher ausnahmslos Debian eingesetzt, weil ich Ubuntu aufgrund der Aktualität der Pakete eher im Desktop-Bereich sehe. Allerdings habe ich mich heute dazu entschlossen, einen unserer Server auf Ubuntu (20.04) umzustellen. Dort wird übrigens standardmäßig PHP 7.4 ausgeliefert. Ob das nun die richtige Entscheidung war, wird sich zeigen. Aber bisher sehe ich das recht entspannt. Es funktioniert alles und ist performant, das ist erst einmal die Hauptsache.

  • PHP 7.4, aber deren Verbreitung ist leider noch nicht ausreichend.

    Ich verwende Aktuell 7.4 und bin damit sehr zufrieden, aber Aktuell lese ich überall. PHP 8 das mega ding.

    Kam ja hier auch schon vor.

    Also ab wann würdest du zu PHP 8 raten?

  • SoftCreatR auf Nginx?


    Ausschließlich. Apache setze ich schon mindestens 10 Jahre nicht mehr ein.


    Ich nutze nginx-mainline aus dem PPA von Ondrej und einige Zusatzmodule, die ich selbst kompiliert habe. Bisher habe ich den nginx immer selbst kompiliert, mit allen Modulen, die ich benötige. Davon wollte ich weg, weil das dein System zumindest auf Dauer in einen ziemlich instabilen Zustand versetzen kann.


    PHP (8) nutze ich ebenfalls aus dem PPA von Ondrej. Ob der Einsatz von PHP 8 zum gegenwärtigen Zeitpunkt sinnvoll ist, muss letztlich jeder für sich entscheiden. In den meisten Fällen empfiehlt es sich allerdings, einfach die vom Maintainer bereitgestellte Version einzusetzen. Dann ist man auf der sicheren Seite. Bei Debian ist das glaub PHP 7.2, bei Ubuntu eben 7.4. Hast du etwas mehr Erfahrung, kannst du auch mehrere PHP-Versionen parallel betreiben und um Bedarfsfall einfach wechseln.

  • Ich fahre da aktuell eine Zweigleisige Schiene.


    Auf dem Live-Server läuft bereits alles mit PHP8, die lokale Entwicklungsumgebung aber noch auf PHP7.4, da es kein Redis PECL für Windows gibt bisher das PHP8 Support hat.

    Projekte:

    XIVDATA - Eorzea Database


    A red dragon falls from the heavens... Ah, that memory has been lost. A shame. It was a favorite of mine...


  • Ich fahre da aktuell eine Zweigleisige Schiene.


    Auf dem Live-Server läuft bereits alles mit PHP8, die lokale Entwicklungsumgebung aber noch auf PHP7.4, da es kein Redis PECL für Windows gibt bisher das PHP8 Support hat.

    Bei mir genau andersrum xD auf dem Liveserver läuft PHP 7.4 und auf dem Testsystem PHP 8.0 :D

  • Also, ich hab nur noch PHP8 am laufen. Und von Nginx auch die Mainline Variante. Beides bezogen via Ondrej PPA.

    „If you can only do one thing, hone it to perfection. Hone it to the utmost limit!“ – Zenitsu Agatsuma

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!