PackageInstallationPlugin-Benennung vereinheitlichen

  • App
    WoltLab Suite Core

    Hallo,

    ja, mal wieder ein bisschen was, um die Klassenbenennung in WCF 2.0 zu vereinheitlichen, genauer die PackageInstallationPlugins:

    • Sollte ACPMenuPackageInstallationPlugin nicht korrekterweise ACPMenuItem(s)PackageInstallationPlugin heißen, da die Menüpunkte die Elemente sind, die installiert werden; das gleiche gilt für PageMenuPackageInstallationPlugin?
    • Sollte LanguagesPackageInstallationPlugin ebenso nicht eher LanguageItemsPackageInstallationPlugin heißen? Zwar werden auch Kategorien installiert (bei den Options aber auch) und die Sprache wird noch dem Paket zugeordnet, primär werden ja aber Sprachvariablen installiert.
    • Allgemein ist es aktuell wenig einheitlich, ob die zu installierenden Elemente im Klassennamen im Plural verwendet werden (meistens) oder im Singular (EventListenerPackageInstallationPlugin, PageLocationPackageInstallationPlugin, TemplateListenerPackageInstallationPlugin), was man anpassen sollte, wobei es natürlich bei manchen Plugins sinnvoll ist, den Singular zu verwenden, zum Beispiel beim ScriptPackageInstallationPlugin.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!