Zwingende Labelauswahl

  • Affected App
    WoltLab Suite Forum

    Hallo,


    folgender Aufbau:


    - 2 Labelgruppen (jeweils zwei Label) -> die zweite Labelgruppe muss zwingend ausgewählt werden
    - Bei beiden ist die Benutzergruppe "Jeder" sowohl mit Seh-/Auswahlberechtigung hinterlegt



    Szenario 1:


    Erstelle ich nun ein neues Thema und wähle gar kein Label aus:



    Hier schon komisch, da er eigentlich nur beim zweiteren Labelfeld sich aufregen dürfte...


    Szenario 2:


    Man befolgt ja brav dem Hinweis und wählt nun im Labelfeld 1 was aus:



    Das Label wird ignoriert, stattdessen wird wieder gesagt kein Label ausgewählt und zudem das Formular zerfetzt...


    Szenario 3:

    Da ich ja weiß, dass die Labelgruppe 2 dem Auswahlzwang unterliegt ignoriere ich die Meldung zu Label 1, wähle im Label 2 was aus und siehe da: es klappt.



    Eingesetzt wird Beta 4, bin da mehr durch Zufall durch eine andere Applikation darauf gestoßen und vermutete den Fehler dort (zu meiner "Freude" lässt es sich zum Glück auch im WBB reproduzieren :whistling: 8) )


    Mfg Cr@@gle

    • Official Post

    Der eigentliche Fehler ist behoben.


    Zu der Fehlermeldung: Die bezieht sich darauf, dass bei der Label-Auswahl allgemein, nicht bei der ersten Label-Gruppe, ein Fehler aufgetreten ist, auch wenn der Pfeil hier auf die Auswahl der ersten Label-Gruppe zeigt, was jedoch einfach am globalen CSS-Code liegt, der den Pfeil positioniert. Ggf. hier eine eigene Fehlermeldung bzw. einen Vorschlag schreiben :) .

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!