Symlink installation bug

  • Affected App
    WoltLab Suite Forum

    I have the following setup on my testservers:

    Linux machine
    Apache webserver with DocumentRoot pointed to /srv/http
    User 'test' with $HOME in /home/test
    Symlink from /srv/http/test to /home/test/htdocs/public
    Symlink from /home/test/htdocs/public to /home/test/files/wbb4

    So at the end, I unpacked and installed the WBB4 beta to /home/test/files/wbb4.

    During installation, I got no errors. After the installation has finished, WBB4 tries to redirect me to http://{$DOMAIN}/home/test/files/wbb4/acp/[...]
    This is a wrong redirect and ends of course in a 404. The correct redirect would be to http://{$DOMAIN}/test/acp/[...]

    I tried to set the parameters you can change during the installation (WCF installation directory, public URL, ...) to many different values; to the symlink on /srv/http, to the symlink in /home/test/htdocs, without the symlink... Nothing works, I always get the wrong redirect.

    The result is, that after the installation, nothing works. If I manually correct the URL, I get to see the correct page, but all hyperlinks in that page (and also the form-targets) again point to the incorrect URL.

    If you need more info, let me know.

  • *push*

    Independent of whether it would work when I would adapt the paths in 'wcf1_application': This is definitely a bug during the installation and should be fixed.

  • *push*

    This has been marked as a duplicate - but where can I find the original bugreport? I tried to search for it but I couldnt find it...

    This bug still exists in the beta4 release.

    Manually changing the path in the `wcf1_application` table does of course fix it.
    To provide more info:
    The `domainPath` for `packageId`='4' (WBB) was set to '/home/test/files/wbb4/'. Manually changing it to '/test/' fixed the problem.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!