Update auf 3.0.4 - Patchen macht Probleme

  • hallo dudes - habe mein forum auf 3.0.4. upgedated


    es kommt aber immer folgende meldung:




    Was kann ich tun?

  • Auch bei mir heißt es
    error message: Can't find an appropriate location for applying this hunk.
    (zu Deutsch: Fehlermeldung: kann nicht eine passende Position für das Anwenden dieses großen Stücks finden.)


    affected template: boardThreads
    patcher: de.wbb3mods.wbb.board.languagemark
    affected template: subscriptions
    patcher: de.wbb3mods.wbb.board.languagemark
    affected template: searchResultPost
    patcher: de.wbb3mods.wbb.board.languagemark


    Wie weiß ich nun, welches Plugin gelöscht werden muss?


    Ich habe 59 Pakete installiert. Keines heißt Threadsprache.
    Ich nehme an, dass das Paket Thread Languagemarks deinstalliert werden muss.
    Richtig?

    Und wiederholt sich das jetzt bei jedem Update?
    Je mehr Plugins, desto mehr manuelle Löschungen und Wieder-Installationen?


    8)

  • Vom einstigen *WBB 3 macht beim Update keine Probleme mit Addons* ist scheinbar doch nicht viel übrig geblieben.
    Hab auf dem Testsystem versucht zu installieren, blieb kommentarlos stehen. Nachdem ich ich dann ein Profil-Addon entfernt hab, ging es. Heißt aber auch dass ggf. beim deinstallieren bestehende Daten mit gelöscht werden und die Mitglieder wieder alles neu machen müssen.
    Bisher ging noch kein Update ohne Probleme, und ich hab kaum Addons installiert. Zumal man ja von Woltlab dazu angehalten wurde, weggelassene Funktionen aus dem WBB 2, die doch viele wollten, als Addon einfach wieder zu installieren. Und wenns Probleme gibt beim Update, heißt es, selbst schuld, wenn man Addons installiert.

    • Official Post

    Vom einstigen *WBB 3 macht beim Update keine Probleme mit Addons* ist scheinbar doch nicht viel übrig geblieben.

    Doch ist es :!:


    Vielleicht solltest du, bvevor du hier so eine Behauptung aufstellst, erstmal beachten, welche PlugIns da Probleme machen. Da haben sich die Entwickler wohl nicht an unsere PlugIn-Vorgaben gehalten. :(


    Korrekt aufgebaute PlugIns machen keine Probleme! ;)

    "Viribus Unitis"


    Harald Székely
    Designer

  • Hi,


    also ich konnte problemlos updaten und habe folgend Plugins installiert:




    • ModCP Patch
    • HeaderMenü-Edit
    • Highslide WBB
    • Highslide WCF
    • Edit BBCode
    • Profile last Visitors
    • AdminOfflinewarung
    • Erweiterte Benutzerauflistung
    • IRCStats
    • Current Ranks
    • Nerdz BBCode Video
    • Advancend Header with ModCP and Guestinfo
    • Ankündigung
    • Banner Rotation
    • Birthday on Index
    • eMail on Birthday
    • Flohmarkt
    • Flohmarkt Bewertungen im Profil
    • Flohmarkt im Erweiterten Header mit ModCP
    • Forenregeln
    • Impressum
    • IRC-Chat
    • New on edit
    • PM AutoDEL
    • PM AutoDEL Template
    • RSS Feed WIW
    • Treuesterne Profil und PM
    • Treuesterne Thread
    • Wer ist im IRC (Eggdrop)
    • WCF Instant Messenger
    • Instant Messenger wBB Erweiterung
    • Thread: Coloured Names
    • Abwesenheits-Assistent
    • Text 2 Shield
    • FootScript
    • G-Map BBCode
    • Google Analytics
    • Google BBCode
    • G-Map
    • G-Map for WBB
    • Delete Inactive Users
    • Hide Smilies
    • Top5 Themen
    • Users were online
    • wBB Statistik
    • Who Was Online (wBB 3.0)


    Davon machte lediglich das Plugin Profile last Visitors leichte probleme.

  • Quote

    Vielleicht solltest du, bvevor du hier so eine Behauptung aufstellst, erstmal beachten, welche PlugIns da Probleme machen. Da haben sich die Entwickler wohl nicht an unsere PlugIn-Vorgaben gehalten. :(

    Ich wüsste nicht das es schon dafür eine Templateschnittstelle für $additionalSmallPages gab ;).


    Der Fehler liegt einfach darin, das Woltlab nun neue Schnittstellen dort eingebaut hat, wo vorher der Templatepatch des Plugins ausgeführt wurde. Durch diese Maßnahme wird auch ein Templatepatch überflüssig. Allerdings muss dazu natürlich erst eine angepasste Version des Plugins veröffentlicht werden.

    Quote

    Und wiederholt sich das jetzt bei jedem Update?
    Je mehr Plugins, desto mehr manuelle Löschungen und Wieder-Installationen?

    Nein das sollte nicht die Regel sein! Dieses Plugin war ganze 8 Bugfixversionen des wBB3 ohne Probleme zu installieren, nur bringt diese Bugfixversion endlich die erhofften und gewünschten Schnittstellen mit.

    "coding styles are like assholes, everybody has one, but nobody likes anyone elses"
    KEIN SUPPORT PER PN!


  • Also soweit lief bei mir selbst beim Template-Patchen alles super.


    Nur, das meine Startseite jetzt komisch aussieht.....kann ich mir nicht erklären :(


  • Bei mir kommt das hier:



    Abbruch bei 94%


    Kann damit jemand was anfangen und mir helfen?


    ROLF

  • Also bei mir gab es auch Probleme, aber dann bin ich auf; System => Paketverwaltung => Automatische Updates => und dann die erstmal die wichtigsten Sachen geupdatet, wie z.B wbb 3.0.0.4 und wcf. Nachdem ihr das gemacht habt könnt ihr die anderen Sachen nun ankreuzen zum Updaten. (So jedenfalls is bei mir alles reibungslos gegangen.)