Paketinstallationsproblem?

  • Ich habe eben ein Paket von meinem cms erstellt, in diesem werden PacketPluginserstellt.

    Nun bleibt er bei der Installation bei 93% hängen das ist genau da wo er das sach installiert. ( Paket-Installations-Zusatzmodule werden installiert ... )

    Es kommt keien Fehlermeldung oder sonstwas sondern er bleibt einfach nur stehen, an was kann das liegen?


    Ist das ein Bug vom WCF oder hab ich einen Fehler im Packet?
    Oder ist das normal das er über 3 Minuten an der Stelle hängen bleibt.

    Gruß Alex

  • Wie sieht denn dein PIP aus? Benutzt du Exceptions?
    Am besten du loggst dir die Fehlerausgabe deines PIPs mal in eine Logdatei.

    FSK 12 - Der Gute kriegt das Mädchen
    FSK 16 - Der Böse kriegt das Mädchen
    FSK 18 - Alle kriegen das Mädchen

  • Ich bekomme ja leider keine Fehlerausgabe.

    HAbe mal im Anhang das pip und die xml Dateien die ich dazu erstellt habe.
    Und noch zusätzlich die package.xml


    Edit: Ok Fehler gefunden hatte in dem einen pip eine Falsche class drin, vllt sollte man da auch noch eien FEhlerAusgabe machen das man weiß woiran das liegt warum es nicht weitergeht.

  • Ok es ist scheins doch noch ein Fehler oder vllt auch ein Bug, ich weiß es nicht genau.

    Er sagt nun das es die constante CMS_N nicht gibt, wie kann ich das Problem lösen?


    Edit: Achja Es handelt sich ja um ein Standalone Paket was eben eigene Import Möglichkeiten über das pip mit bringt, ich hoffe man versteht was ich meine.

    Gruß Alex

    Edited once, last by Griborim (March 5, 2007 at 10:48 PM).

  • Mhh weiß niemand wie ich das lösen kann, es scheint ja dran zu liegen das er die constante abruft bevor diese definiert wurde, vllt. sollte man das ausführen der pips ganz ans ende schieben.


    Edit: Ok ich weiß nun woran es liegt, es wird jeweils nur die wcf config.inc.php und die von der Endanwendung von der das ganze gerade installiert wird includet.

    Vllt sollte man es so machen das die config.inc.php auch includet wird von der jetzt gerade Installierten Endanwendung, da ja die config.inc.php schon vor dem ausführen erstellt wurde.


    2. Ich habe nun eien Fehler Meldung bekommen undefined index className. woran kann das liegen?
    Habe ich in der boxes.xml einen falschen Namen angegeben oder durch was kommt das.

    Das komische ist das er keine Meldung bringt das die nicht definiert wurde trotz das es abgefragt wird.

    Code
    if (!isset($boxesItemData['className'])) {
    throw new SystemException("Required 'className' attribute for Incendium Box item tag is missing.", 13023);
    }

    Und hier wird es in eine Variable geschrieben.

    Code
    $className = $boxesItemData['className'];


    Und genau in dieser Zeile tritt dann auch der Fehler auf.

    Gruß Alex

    Edited 2 times, last by Griborim (March 6, 2007 at 3:05 PM).

  • Ja habs nun gemerkt und geht nun 1a.


    Burntime hast du eine Idee wegen dem Problem mit denn Konstanten, siehe genaueres hier.

    Bei eigenen PIP cachen?

    Das einzige was mir einfällt ist es als wcf tabelle zu machen oder als erweiterung fürs wcf, aber das wär nicht so gut die Lösung da es dann eigl das ändern würde was ich vorhatte.

    Gruß Alex

  • Ok, hab das nun wie im oberen Thread von Burntime empfolen gemacht, nur leider kommt keine Fehlermeldung und nichts. Er bleibt einfach beim Schritt wo er die Box Daten einfügt hängen ( 95% ) und es geht nicht weiter, wie kann ich nun herausfidnen woran es liegt das er nicht weitergeht?
    Ich habe schon in phpMyAdmin geschaut die Daten wurden in die Tabelle eingetragen, also kann es ja Scheins nicht mit der Variablen zu tun haben oder?


    Ok habe die Ursache gefunden, mal sehn wie ich das beheben kann.

    Gruß Alex

    Edited once, last by Griborim (March 7, 2007 at 9:44 PM).

  • Ja ich weiß nun woran das liegt er sagt das es die eine fucntion nicht gibt, liegt vermutlich daran das er die nicht finden kann in meiner function, ich werde das anders lösen denk ich mal was auch geht und der gleiche Zweck hat.

    Gruß Alex

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!