Forum in Testinstalation

  • Dann macht es natürlich Sinn, stimmt.


    Ähnlich historisch vielleicht auch wie der alte Umstand unter Windows, dass dieses nicht mit "Dotfiles" zurecht kommt (also Dateien mit Extender, aber ohne Dateinamen davor wie z.B. die ganzen .htxxx Files).

    Während das für unixoide Plattformen ja völlig normal ist, weigert sich Windows beharrlich gegen deren Verwaltung.


    Ok, long story short: Bleiben wir also bei der Empfehlung, alles im Binär-Modus zu übertragen. :)

    Gruß

    Jörg

    (Jaydee)

  • Dieser "Auto-Modus" lässt sich in modernen Clients wie z.B. dem FileZilla einstellen und das würde ich Dir auch empfehlen. Dann musst Du ich um nichts mehr kümmern, was diesen Punkt betrifft.

    Ich habe eben mal nachgeschaut was bei meinem Filezilla aeingestellt ist.

    Wenn ich das richtig sehe ist es gleich eingestellt wie bei dir, wie man hier sehen kann




    Bei welchem Hoster bist du denn, Leandra? Gibt es da im Kundenbereich keine Möglichkeit Daten per FTP zu übertragen oder sogar auch Datenbanken?

    Wir sind auf Gn2 Hosting Unter dem Ordner FTP kann ich nichts machen, nur schauen wie die Einstellung ist, also benutzername, pw,a ber auf FTP zugreiffen gent nur über den Filezilla den ich auf PC habe.


    Betreffend DAtenbanken, da können wir, beim Hoster, einen weiteren Ordner sehen wo Mysql drauf steht. Klickt man da sieht man alle Foren, Testboards die eine Datenbank haben. Kann da ja auch neue Datenbank erstellen. Klicke ich dann hinten auf drei Striche öffnet sich ein klenes Fenster das hier



    Klicke ich da auf Verwaltung dann lande ich eben in phpMyAdmin 4.8.5 in der Datenbankdes Forums oder Testboards. Im phpMyAdmin sehe ich oben dies hier



    Rot markiert Export und Import, mit denen ich gearbeitet hatte. 1 in Forum Datenbank den Export geklickt, dann dauerte es nicht lange bis das Teil fragte wo ich das Abspeichern will. Danach in der Testumgebung, neuer Ordner ohne Testboard drin, auf Importieren geklickt, damit dann die vorher vom Forum exportierte Datenbank in die Testinstallation importiert. Resultat hatte ich schon beschrieben, rote Seite, mit viel geschreibsel, das ich nciht verstand. Damit das Forum aber nciht zu zicken anfing habe ich da abgebrochen, die Testinstallation gelöscht.


    Also das was ich bisher schon sagte, nun einfach noch mit Bildern dargestellt damit man verstehen kann was ich gemacht hatte.

    Bei FTP mache ich es so, das ich den betr Ordner wo das Forum drin ist, auf PC runterlade, es verschwindet dann ja nicht aus dem FTP sondern erstellt eine Kopie dessen was da drin ist. Das machte ich bisher immer wenn ich ein Backup erstellte, weil das wurde mir vor Jahren mal so erklärt. DAnn soll man noch im ACP auf Sichern & Wiederherstellen gehen, da auf Sicherung der Optionen herunterladen. Das habe ich auch immer gemacht wenn ich ein Backup vom Forum erstellen wollte.


    Sollte das nun völlig falsch sein um Backups zu machen, dann bedanke ich mich bei denen, die mir damals Mist erzählt haben.

  • Ja, die Einstellungen sind soweit identisch, vielleicht abgesehen von der Ausnahmeliste.

    Die ist aber nicht wichtig, wenn man ohnehin den binären Modus (für alle Dateienarten) erzwingt.


    Zum Hoster-Panel: Nicht alle Hoster erlauben auch den FTP-Zugriff über das Domain-Panel. Einige zeigen in der Tat dort nur den Domain-Namen, Pfade etc. und das wars.

    Aber suche dort mal nach z.B. "Web-Browser" oder "Dateiverwaltung" und ähnlichem, manchmal ist die direkte Verwaltung an anderer Stelle möglich.

    Nur heißt der Punkt bei jedem Hoster anders und man muss ggf. etwas danach suchen.

    Ansonsten mal den Hoster-Support fragen, ob das überhaupt dort möglich ist.


    Falls ja, kannst Du auch direkt über das Panel Dateien hoch/runterladen, Rechte setzen und manchmal auch direkt dort Files in einem Editor bearbeiten, ohne sie erst lokal laden zu müssen.

    Das ist aber extrem Hoster-abhängig, ob und wie das funktioniert.

    Gruß

    Jörg

    (Jaydee)

  • Wie gesagt, mit PhpMyAdmin ist die Datenbank oft zu groß, um sie einfach so zu spiegeln. Ich befürchte, da musst du auch ein Tool wie HeidiSQL benutzen. das musst du auf deinem PC installieren:

    https://all-inkl.com/wichtig/a…ng-zur-datenbank_418.html

    https://all-inkl.com/wichtig/a…icherung-anlegen_419.html

    https://all-inkl.com/wichtig/a…elen-importieren_420.html

    Du musst erst dein Liveforum damit sichern und dann die leere Datenbank anlegen, dich damit verbinden und dann das File dort rein laden.

    Also was ich sicher sagen kann ist dass das Forum nicht so riesig ist, denke das sollte bei dem Hoster, über Datenbank export und dann import kein Problem sein. Die Hilfe di e ich ahte beim wchsel von wbb 4.1 uf das wsc 3.1 hat da soweit ich das weiss auch neue Datenbank angelegt und dann das 3.1 da rein, danach über Importer alles von Forum rein gepackt, danach noch irgendwas geändert damit das dann den selben Link behalten konnte im wsc3.1 wie er im Wbb 4.1 war. Er meinte dass der Wechsel von wsc 3.1 auf das wsc 5.2 dann deutlich einfacher sei, als von wbb 4.1 auf das wsc 3.1 Doch nach allem was ich hier gelesen habe sehe ich nichts was einfach sein soll.


    Zum anderen, wegen Datenbank export und Import, ich hatte ja schon die Datenbank von Liveforum, über den Mysql exportiert, auf PC, da war kein Problem dabei. Erst beim Importieren in testbaord hat es nicht geklappt.


    Was ist mit dem File gemeint? meinst du die DB von Liveforum oder noch was anderes?

  • Ich habs generell auf "Automatisch" stehe und fahre damit bisher bestens. Sollte der Client tatsächlich mal mit einer einzelnen Datei nicht klar kommen, überspringt er diese zunächst und meckert den Vorgang an. Das kam aber über die Jahre extrem selten vor und das kann man dann manuell korrigieren. Die korrekte Übertragung wird beidseitig immer vom Client überprüft und am Ende bestätigt.

    Das eine hat mit dem anderen nichts zu tun. Im ASCII-Modus werden Dateien verändert. Und das möchte man doch eigentlich eher nicht. ;)

  • HeidiSQL erzeugt ein File, genauso wie dein phpMyAdmin. Und das muss man in die neu angelegte Datenbank einlesen. Wenn das per phpMyAdmin nicht geht, packt php das wahrscheinlich nicht mehr (ist jetzt nur eine Vermutung, denn die Fehlermeldung aus der das eindeutig hervor gehen könnte, hast du nicht gepostet) und dann wäre HeidiSQL die mögliche Alternative.

    Liebe Grüße
    Susi

  • Ich denke, das Hostingpaket wird zum einen keinen SSH User mitbringen, zum andere würde ich annehmen, Leandra würde das noch komplizierter finden. Aber sollte ich mir irren, kannst du gerne Schritt für Schritt erklären was zu tun ist.

    Liebe Grüße
    Susi

  • Oder der (PHP 7.x) Nachfolger vom MySQLDumper, MyOODumper.

    Er basiert auf der Version 1.24.4 und wurde für PHP 7 lauffähig gemacht, der Rest funktioniert wie bisher.

    Damit sicherst Du entweder via PHP und darüber mit Selbstaufrufen, um das Timeout zu umgehen, oder aber sogar mit Perl und Cronscript.

    Der erzeugte Dump kann wahlweise per Mail verschickt oder sofort auf dem Server abgelegt werden. Das Verzeichnis wird per .htaccess-Schutz vor möglichem Fremdzugriff gesichert (falls jemand das Verzeichnis erraten sollte und es testet).


    So oder so wird dabei immer der Erfolg gemeldet, so kannst Du sicher sein, dass ein Backup auch wirklich komplett ist.

    Die PHP-Sicherung kannst Du an Deine Server-Umgebung anpassen, also auch auf schwächere Server und kürzere Timeouts einstellen.

    Dann erfolgen zwar mehr Selbstaufrufe und dadurch dauert die Sicherung länger als bei höheren Werten, ist aber ebenso sicher und vollständig.


    Das alles gilt aber hauptsächlich, wenn Du KEINEN SSH-Zugriff hast (oder DIh mit Konsolen nicht auskennst). Ansonsten würde ich diese Methode (via mysqldump) immer vorziehen, zumal sie auch schneller ist.

    Gruß

    Jörg

    (Jaydee)

  • Welches Paket hast du denn hier? https://www.gn2-hosting.de/hostingtarife/


    Allgemein gilt wohl, dass der Hoster Sicherungen macht. Vielleicht kannst du ihn bitten, diese auf einer extra Umgebung bereit zu stellen. Dann müsstest du nur die Schritte ab 3. durchführen:

    RE: Forum in Testinstalation


    Gleichzeitig könntest du testen, ob die gezogenen Backups überhaupt funktionieren. Tun sie das nicht, musst du dich kümmern, das auf den Weg zu bringen, denn das ist DSGVO relevant. Da du rechtlich keinen Anspruch auf diese Backups hast, solltest du dich aber ohnehin um eigene kümmern.


    Ich sehe in den Paketen keine Cronjobs, aber irgendeine Möglichkeit scheint es dafür dennoch zu geben.
    https://wissen.gn2.de/wissen/e…-einem-cron-job-aufrufen/


    Na ja, aber eins nach dem anderen würde ich sagen.

    Liebe Grüße
    Susi

  • Welches Paket hast du denn hier?

    Wir sind zu zweit auf einem Server, die Freundin hatte sich sonst immer darum gekümmert, war Kunde bois vor kurzem. Dann haben wir auf mich übertragen aus versch. Gründen, die nicht hier her gehören.

    Wenn ich das also richtig sehe, dann haben wir das letztere der aufgelisteten Pakete. Muss aber ganz klar dazu sagen, dass ich da noch nicht den kompletten Überblick habe.


    Was ich sicher sagen kann ist das der Hoster auch rtegelmässig Backups macht, da waren wir auch schon froh drum als eine Störung auftrat in einem unserer Foren. Damals hat man uns das schnell erledigt mit Backup einspielen aber das ist normalerweise nicht Kostenfrei.


    Alles andere mit dem SSL und was sonst noch vorgeschlagen wurde, hilft mir leider nicht viel weiter, im Gegenteil, ich habe je länger je mehr das Gefühl das ich unglaublich viel machen, umstellen, bedenken, irgendwo was eintzragen, etc muss nur um eine Kopie des Forums in eine Testinstallation zu bekommen. Vorallem verwirrt es mich, wenn der eines agt mach es so und dann kommt der andere sagt ui nee so ist nicht gut das muss du so machen.... Ihr macht das scheinbar alle auf unterschiedliche Weisen und ich dachte es sei keine überaus komplizierte Sache, das ganze war einfacher, vor Jahren, da brauchte es FTP, DATenbank Backup, das ganze ind ie entsprechenden neuen Ordner einfügen basta. Heute muss man dies und das ändern jene Datei irgenwas einfügen dort was rausnehmen, da hinten was anderes einstellen. Iéch sehe nur noch Wald aber keine Bäume mehr.


    Da klingt die Beschreibnung betr. Update von wsc 3.1 auf das wsc 5.2 von Woltlab Update von WoltLab Suite 3.1 auf WoltLab Suite 5.2 richtig einfach und leicht. Nur ob das dann geht beim Forum, wenn es beim Testboard klappt das ist die grosse Frage und die kann mir keiner Beantworten das weiss ich.


    Folglich bleiben mir sehr wenige Möglichkeiten.


    - Ich erstelle in Testboard paar Foren, ein paar Accounts, haue alle Stils und Plugins rein die im Forum sind und versuche mein Glück. Wenn es klappt ok. DAnn kann man nur noch Hoffen und Beten das es im Forum genau so gut geht, wenn nicht, ist es eine ganz grosse scheisse.


    - das ganze Update auf das 5.2 einfach vergessen, weil ich verstehe hier je länger je mehr Bahnhof, stehe verwirrt da weil der eine dies sagt der andere sagt nein mach es nicht so, sondern anders rum, und der dritte hat auch noch eine Idee was ich machen könnte. Ich bin Anfänger, kein Profi, was ich nun schon mehrfach sagte.


    - wieder Geld ausgeben, damit in Testboard die Forumkopie rein kommt und später nochmal die gleiche Summe ausgeben um das Forum auf die 5.2 zu kriegen. Das Geld wächst ja bekanntlich wie Gras an jeder Ecke, nur hier in unserem Dorf fan noch keiner solche Ecken.

  • Deshalb komme ich mehr und mehr zu der Erkenntnis (was ich weiter oben ja schon angedacht hatte), dass es für Dich vielleicht doch sinnvoll ist, die ganze Geschichte einem Co-Admin anzuvertrauen.

    Der Lern-Aufwand dürfte doch ziemlich gewaltig sein, wenn man das alles auf einmal stemmen soll und mehr oder weniger "bei Null" damit anfängt, ohne große Vorkenntnisse.


    "Unsereins" ist da über Jahrzehnte und auch beruflich hinein gewachsen, da ist jeder neue Schritt deutlich einfacher und selbst dann muss man noch laufend dazu lernen und umdenken, weil die IT-Branche extrem schnelllebig ist und auch die Anforderungen durch schnell wachsendes Internet immer größer werden.

    Dabei gehört dann Server-Betreuung und PHP/MySQL-basierte Anwendungen fast noch zu den "einfacheren" Dingen.


    Solange man da bei jedem 2. Fachbegriff mit den Ohren schlackert und fragen muss "was ist das, nie gehört?", ist es sehr wahrscheinlich besser, sich einen Fachmann dafür zu holen als selber zu fummeln.

    Gruß

    Jörg

    (Jaydee)

  • Kann ich verstehen, dass dich zu viele Infos verwirren, aber letztendlich muss hier jeder ausprobieren, was ihm am besten liegt, wenn es mehrere Möglichkeiten gibt. Man kann dir erst weiter helfen, wenn du einen Weg davon ausprobierst und dazu eventuell konkrete Fragen stellst.


    das ganze war einfacher, vor Jahren, da brauchte es FTP, DATenbank Backup, das ganze ind ie entsprechenden neuen Ordner einfügen basta.

    So ist es ja auch nach wie vor, nur das mit wachsendem Datenbestand eben nicht mehr alles ganz so geht, wie ganz zu Anfang. Die passende Datenbank zuordnen musste man aber wirklich schon immer.


    Aber wenn dir das alles zu kompliziert klingt, wirst du wohl wirklich wieder jemanden beauftragen müssen.

    Liebe Grüße
    Susi

  • Ich habe mir nun einige Gedanken gemacht und will es noch mal versuchen. Folgendes ist meine Überlegung, die ich noch nicht ausprobierte.


    Ich erstelle eine neue Datenbank, ohne irgendwas hochzuladen, als neue Testinstalation, neues Testboard.

    Das alte Testboard lösche ich komplett, weil da schon einiges drin ist und das alles zu löschen dauert lange. Da ist eine Neuinstallation schneller erledigt und die hat dann nix drin das irgendwas blockieren könnte.


    Dann gehe ich in Datenbank von Liveforum, exportiere diese auf PC.


    Danach gehe ich in Filezilla, lade den ganzen Ordner vom Liveforum auf PC runter. Im ACP kann ich noch die Optionen runterladen.

    So habe ich das ganze Backup vom Liveforum auf dem PC, soweit ich weiss.


    Danach gehe ich in die neue erstellte Datenbank (neue Testinstallation), wo noch nichts drin ist, importiere da die Datenbank von Liveforum, die auf PC ist.

    Soweit ich das verstanden habe sollte das so klappen.


    Was muss ich nun machen/ändern, damit die Kopie des Forums im Testinstallation aufgrufen werden kann?


    Muss ich dann in Fillezilla, in der Testinstalation, die config.inc.php suchen und da die Zugangsdaten der Datenbank ändern, weil da dann vermutlich die Angaben von Forum drin sind?


    Weil in der Beschreibung von "Update von WoltLab Suite 3.1 auf WoltLab Suite 5.2" ganz unten steht


    Quote

    Appendix A: Entfernung der Option "Speicherort der Dateianhänge"

    Die Option "Speicherort der Dateianhänge" wurde in der WoltLab Suite 5.2 standardmäßig entfernt und steht nur noch indirekt zur Verfügung. Falls Sie die Option verwenden, sollten Sie vor der Durchführung des Upgrades den Pfad direkt konfigurieren, damit die Dateianhänge korrekt verarbeitet werden können. Bearbeiten Sie dazu bitte die Datei config.inc.php im Installationsverzeichnis von WoltLab Suite Core, diese enthält unter anderem die Zugangsdaten zur Datenbank. Fügen Sie am Ende die folgende Zeile an....


    Dann müsste ich da, in der confic.inc.php die Datenbank der Testinstallation eintragen, wenn ich das richtig sehe.


    Ist meine Überlegung richtig oder falsch?



    Wenn meine Überlegung falsch ist, habe ich drei Fragen


    1. In welcher Datei muss ich eine Änderung machen?


    2. Wo genau finde ich diese Datei?


    3. Was genau muss ich in der Datei ändern?



    Hoffe das Hirnen die letzte Nacht hat was gebracht und ist nicht nur Müll wert. Das ist wirklich der letzte Versuch das ganze hinzukriegen.

    Wenn das nichts ist, dann dann gebe ich endgültig auf.

  • Was muss ich nun machen/ändern, damit die Kopie des Forums im Testinstallation aufgrufen werden kann?

    So wie es hier steht: RE: Forum in Testinstalation

    Du musst nichts "installieren". Du musst wirklich nur die datenbank importieren und die Files alle hochladen.


    Muss ich dann in Fillezilla, in der Testinstalation, die config.inc.php suchen und da die Zugangsdaten der Datenbank ändern, weil da dann vermutlich die Angaben von Forum drin sind?

    Genau


    Dann müsste ich da, in der confic.inc.php die Datenbank der Testinstallation eintragen, wenn ich das richtig sehe.

    Richtig und wenn du alles normal installiert hast, sollte diese Datei im "root" der Subdomain oder dem Unterordner stehen.


    Falls dich die Anleitung von Geronimo verwirrt, dann schaue wieder in mein Posting für die Schritte, denn du musst keine Files verschieben, sondern sie von deinem Rechner in die Testumgebung kopieren. Grundsätzlich geht es ansonsten um Schritt 5, wo du die Pfade auf die Testumgebung anpassen musst. Da hatte ich gesagt, dass ich das immer über die Datenbank mache, dann kann man auch nicht aus dem ACP fliegen. Wenn du es über das ACP versucht, musst du die Reihenfolge einhalten!

    Liebe Grüße
    Susi

  • Ja. Und du wirst die (Sub-)Domain ändern wollen. Hilfreich ist dabei vielleicht der archivierte Artikel Verzeichnisstruktur ändern.


    Ich habe das Testboard auf einer Subdomain und habe dann mehrfach, dessen Datenbank gelöscht, nicht die Subdomain.

    Dann habe ich im FTP den Ordner von Testboard gelöscht. Erstellte da neuen Ordner an gleicher Stelle, mit gleichem Namen, danach erstellte ich eine neue Datenbank, neues Testboard, mit dem gleichen Namen wie zuvor und der Link blieb der gleiche.


    Beim Hoster muss ich die Subdomain ja wo anders einstellen, nicht da wo ich Datenbank erstelle. Also ist die Subdomain schon da.

    Dann wäre der Link subdomain.domain.net in meinem Fall, bei anderen kann die Endung anders sein, z.B. de, oder at oder ch


    Also müsste ich ja keine neue Subdomain machen, wenn schon eine besteht, solange ich die neue Datenbank gleich nenne, wie das Testboard heisst, das ich ja vorher löschen werde.

  • Sorry Susi,

    sah deinen Beitrag erst jetzt nachdem ich die Antzwort abgeschickt hatte.


    Falls dich die Anleitung von Geronimo verwirrt, dann schaue wieder in mein Posting für die Schritte, denn du musst keine Files verschieben, sondern sie von deinem Rechner in die Testumgebung kopieren. Grundsätzlich geht es ansonsten um Schritt 5, wo du die Pfade auf die Testumgebung anpassen musst. Da hatte ich gesagt, dass ich das immer über die Datenbank mache, dann kann man auch nicht aus dem ACP fliegen. Wenn du es über das ACP versucht, musst du die Reihenfolge einhalten!

    Ich Importiere die Datenbank des Forums, die ich vorher auf PC sicherte, in die Testinstallaton, die ich neu erstelle. Wweild as Testboard hat schon SAchen drin da ich da was anderes versuchte, würde also nicht klappen. Folglich lösche ich das und erstelle neue DB nur eben ohne was da hochzuladen, ausser die DB von Forum.


    Das mit den Pfaden, meinst du da den Link der Testumgebung bzw Link von Forum dann eben ändern in den von Testumgebung? Das kann ich in der Confic.inc.php machen. Was müsste dann noch geändert sein?



    Ok habe nochmal nachgeschaut was da steht, was du verlinkt hast.

    Unter punkt 8 hats du geschrieben

    Ich passe immer noch das Cookiepräfix an. Dann kommt da nichts durcheinander - Konfiguration -> Allgemein -> Präfix für Cookienamen


    Ich ging nun in ACP schauen wo das ist. Klickte auf Konfoguration --> Allgemein und suchte nach dem Präfix cfür Cookienamen. WEder oben in den Tabs noch sonst wo sehe ich irgendaws das so oder ähnlich heisst. Ich meine nun das Testboard, das noch da ist.


    Bednke da ist noch wsc 3.1 drauf, nicht wsc 5.2 denn sonstz müsste ich den ganzen Zirkus gar nicht machen, weil wir das Update schon hätten.

  • Das mit den Pfaden, meinst du da den Link der Testumgebung bzw Link von Forum dann eben ändern in den von Testumgebung?

    Konfiguration -> Pakete -> Apps verwalten

    Verzeichnisstruktur ändern

    Du musst die Pfade auf deine Subdomain ändern, wie es in dem Link steht


    Das kann ich in der Confic.inc.php machen.

    Nein, im ACP oder in der Datenbank -> siehe Link oben


    In der Confic.inc.php musst du die Verbindungsdaten zu deiner Testdantenbank angeben.


    Ich habe keine 5.1 Umgebung mehr, aber du kannst auch einfach im ACP nach "Cookiepräfix" suchen. Das gab es auch in 5.1 schon.


    Wenn du denkst, du hast alles abgearbeitet, dann bitte unbedingt prüfen, ob du die richtige Datenbank an deine Testumgebung gehängt hast!

    Liebe Grüße
    Susi

  • Du musst die Pfade auf deine Subdomain ändern, wie es in dem Link steht

    ok habe geschaut, in ACP von Testboard, um zu wissen wo das ist und was im Moment da steht.

    Unter Apps Verwalten ist bei "Woltlab Suite Core", nix im Pfad drin, bei „WoltLab Suite Forum (Burning Board)“ steht beim Pfad wbb, wie das WBB4.1 Forum hiess.

    Muss das dann an beiden Orten geändert sein?


    Warum das eine einen Pfad drin hat das andere nicht weiss ich nciht. Darum die Frage, als Pfad gilt das was ich z.B. in Filezille oben sehen kann wenn ich auf den Ordner von Testboard klicke also das hier /webseiten/seelensturm.net/testboard52

    Genau das gleiche sehe ich auch beim Hoster, wenn ich da auf Subdomain gehe, diese öffne, dann ist da ein Teil das heisst Ziel/PFad darumter kann man auswählen, bei mir ist Pfad drin und im feld dahinter steht dann eben das /webseiten/seelensturm.net/testboard52 genau so wie ich es im Filezilla oben sehe.


    Also wenn ich einen neuen Ordner erstellen würde in FTP (Filezilla) mit dem Namen buntesetwas dann wäre der Pfad /webseiten/seelensturm.net/buntesetwas


    verstehe ich das richtig?



    Ich habe keine 5.1 Umgebung mehr, aber du kannst auch einfach im ACP nach "Cookiepräfix" suchen. Das gab es auch in 5.1 schon.

    habe ich gemacht, das kam raus




    Wenn du denkst, du hast alles abgearbeitet, dann bitte unbedingt prüfen, ob du die richtige Datenbank an deine Testumgebung gehängt hast!


    Ja werde ich machen.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!