Update 1.1.2019 -> Editor fehler

  • Hallo @all und Beitrag Schreiber,

    es bleibt aber die Frage im Raum, ein Mitglied schreibt etwas und speichert. Ohne das er vorher es in Word geschrieben, nach Notepad kopiert um zusehen, ob alles richtig strukturiert ist.

    Nein er nutzt die Plattform und macht sich darüber keine Gedanken, einzig die Mod./Admin sehen das anders und möchten das es "ordentlich"aussieht.

    Und Mir fällt dabei auf, das eben ohne wissen des Mitglied "diese Geister" html-tags in seinem Beitrag erzeugt werden, er schreibt nicht im Quellcode!

    Im Thema fällt das keinem auf, aber auf der CMS (Startseite) wird es falsch Angezeigt!

    So wie auch Zitate nicht angezeigt werden, es kommt zu einer Information ohne Inhalt!


    Frage: Was mache ich mit meinen Mitgliedern, damit es funktioniert beim schreiben von Themen/Beiträgen?


    Natürlich freue ich mich, wenn die aktiven eine Lösung haben bzw. mich auf Fehler im Umgang mit der Forensoftware hinweisen.


    Danke onel01 & HSE24

    Freundliche Grüße HSE24 & onel01

  • Und Mir fällt dabei auf, das eben ohne wissen des Mitglied "diese Geister" html-tags in seinem Beitrag erzeugt werden, er schreibt nicht im Quellcode!

    Na ja, wie denn nun? Du hattest dieses Beispiel mit der Vorlage doch im ersten Post genannt. Wie hast du denn nun die Vorlage genau eingestellt? Hast du die kopiert oder nicht? Es wäre ja schonmal schön, wenn man gewisse mögliche Fehlerquellen ausschließen könnte.


    Allgemein im Text bleibt die Frage wohl bestehen. Es passiert eben manchmal, nicht immer. Wenn du einen bestimmten Fall reproduzieren kannst, dann würde ich ihn nach dieser Diskussion nochmal extra posten, damit das nicht unter geht. Ansonsten bleibt wohl nur zu hoffen, dass Woltlab sich auch der nicht so einfach zu reproduzierenden Probleme annimmt. Ich wüsste nicht, wie das sonst gehen sollte.


    So wie auch Zitate nicht angezeigt werden, es kommt zu einer Information ohne Inhalt!

    Das Problem hatte ich noch nie. Posts ohne Inhalt kannst du eigentlich gar nicht abschicken, es sei denn, du hast das bei dir bewusst so eingestellt. Aber eigentlich gibt es eine Mindestzeichenanzahl. Selbst, wenn nichts angezeigt wird, müssten also Zeichen enthalten sein, die du als Admin ansehen kannst.


    Bei mir passiert es manchmal, wenn ich vor einem Zitat zu nah zu schreiben beginne. Dann verschwindet der Rahmen um das Zitat ungewollt, aber dafür gibt es die Rückgängigtaste im Editor.

    Liebe Grüße
    Susi

  • Na ja, wie denn nun? Du hattest dieses Beispiel mit der Vorlage doch im ersten Post genannt. Wie hast du denn nun die Vorlage genau eingestellt? Hast du die kopiert oder nicht? Es wäre ja schonmal schön, wenn man gewisse mögliche Fehlerquellen ausschließen könnte.

    nicht Kopiert -> Vorlage wurde per Hand geschrieben im Fenster mit Editor ohne Quellcode! Speichern


    Allgemein im Text bleibt die Frage wohl bestehen. Es passiert eben manchmal, nicht immer.

    sehe ich anders, auch heute wieder bei neuen Beiträgen, kommen diese "geister" html-tag`s ohne zu tun der Mitglieder..... sie Antworten nur!


    Posts ohne Inhalt kannst du eigentlich gar nicht abschicken

    das hast Du oder die Leser falsch verstanden, das Zitat (Inhalt/Text usw.) kommt auf dem Dashbord nicht zur Ansicht -> nur Zitat:

    Der Leser/Besucher sieht also nichts, warum das Mitglied das im Beitrag angelegt hat!



    Ich hoffe das dieses Thema nicht verschwindet, da es kein Einzelfall ist was die Nutzung der Plattform/Software im Umgang mit dem Editor betrifft.


    Grüße onel01 & HSE24


    Beide Versionen, Links im Thema als Beitrag; rechts Ansicht Dashbord

    Kann auch gerne den Link zur Plattform geben, da diese öffentlich zu finden ist von google &Co

    Freundliche Grüße HSE24 & onel01

  • das Zitat (Inhalt/Text usw.) kommt auf dem Dashbord nicht zur Ansicht -> nur Zitat:

    Das ist absicht und funktioniert wie gewollt, nennt sich der simplifyed html output und in diesem wird nur dargestellt dass etwas zitiert wurde und nicht der Inhalt, da sich sonst das Zitat nicht vom restlichen Text unterscheiden liese.

  • Guten Morgen @all -> .. Danke Morik ; schaut unschön aus!


    Wie kommt es dazu in der Ansicht Dashbord? :


    ddddddddddddddddddddddddd


    sssssssssssssssssssssssssssssssss


    ssssssssssssssssssssssssssssssss



    Im Beitrag schaut es so aus:

    ssssssssssssssssssssssssssssssssssssss

    ssssssssssssssssssssssssssssssssssssss

    ssssssssssssssssssssssssssssssssssssss


    Danke

    Freundliche Grüße HSE24 & onel01

  • Ich hab keine Ahnung wovon du sprichst, dein Beispiel ist nicht wirklich hilfreich zu erkennen was du nun meisnt...

  • Mal für alle als Bild, damit das Verständnis dazu kommt beim Betrachten.


       


    links der Beitrag / der Quellcode - rechts im Dashbord,

    das meine ich ... "geister" Zeilenumbrüche, wenn ich im Beitrag mir den Quellcode anzeigen lassen.

    Das Mitglied siehst das nicht, aber die Forensoftware erzeugt das im Quellcode und bringt es auf dem Dashbord zur Ansicht und das ist nicht NUR unschön, es nervt wenn man die Beiträge überarbeiten muss, weil das Dashbord eine andere Ansicht bringt Morik und Alexander Ebert


    Haben wir dazu auch eine Erklärung für Anwender und Programmierer?


    Danke

    Freundliche Grüße HSE24 & onel01

    • Official Post

    Hallo,


    mich verwundert das HTML des Beitrags, wieso steht dort vor dem </p> jeweils ein <br>? Das sieht für mich alles nach einer Vorlage aus, wie kommt denn diese zustande? Manuell vom Benutzer per Kopieren & Einfügen angelegt oder wird hier durch ein Plugin eine Vorlage bereitgestellt?

  • Das dürfte erneut, wie vermutet, das Problem aus diesem Post sein:

    Update 1.1.2019 -> Editor fehler


    Er möchte sein eigenes HTML mit <br> als Zeilentrenner erzwingen was sich dann am ende zu dem besagten Problem auswirkt wenn das ganze in paragraphen gesetzt wird.

  • Hallo,


    mich verwundert das HTML des Beitrags, wieso steht dort vor dem </p> jeweils ein <br>? Das sieht für mich alles nach einer Vorlage aus, wie kommt denn diese zustande? Manuell vom Benutzer per Kopieren & Einfügen angelegt oder wird hier durch ein Plugin eine Vorlage bereitgestellt?

    so kommen wir schon mal weiter, Alexander Ebert - Deine Frage kann ich nicht beantworten, da ich Dir nicht sagen kann wer das Erzeugt?

    Was benötigst du, damit man die Ursache finden kann?


    Danke

    Freundliche Grüße HSE24 & onel01

  • Er möchte sein eigenes HTML mit <br> als Zeilentrenner erzwingen

    NEIN -> ich mochte die "Geister" los haben... deswegen bleibe ich an dem Thema dran, wie Alexander Ebert schon schrieb, es muss eine Erweiterung sein.

    - Erweitertes css habe ich nur 3 Einträge, diese bringen NUR Farben zur Ansicht


    Habe diese Ursache auch im Testforum: 30 Erweiterungen im Einsatz

    Liste der Entwickler:

    Von C.Walz, Cr@@gle, Cyperghost, DEvLabor, Florian Gail, Gino Zantarelli, KittMedia, mipu (nmichel), Sascha Greul, SoftCreatR Media, Sonnenspeer, Stefan Larisch, Udo Zaydowicz, WBB-Support und web-produktion


    Alles Entwickler, die schon lange ihre Produkte Entwickeln!


    Danke bei der hilfe um die Ursache zu finden.

    Freundliche Grüße HSE24 & onel01

    • Official Post

    Hallo,


    dann würde ich vorschlagen, es einfach mal strukturiert anzugehen und nacheinander die möglichen Punkte zu klären. Das im Editor oben sichtbare HTML ist "falsch", bzw. entspricht nicht dem Soll-Zustand, daher gilt es einzugrenzen, an welcher Stelles zu dem Problem kommt:

    • Steht initial bereits etwas im Editor, wenn man in exakt dem Forum ein neues Thema starten will?
    • Falls Nein, wurde die Auflistung der Informationen (Einberufung, Dienstgrad, etc.) aus der Zwischenablage eingefügt?
    • Falls Nein, wurde der Beitrag vollständig von Hand verfasst? Welcher Browser- und Version kommt dabei zum Einsatz?
    • Ist das Problem grundsätzlich reproduzierbar oder tritt es nur bei manchen Benutzern auf?
  • Alexander Ebert :

    Trage folgenden text 1 zu 1 in der Quellcode Ansicht des Editors ein und wechsle in die Standard Ansicht, am ende ist es genau das was durch die Themenvorlage geschieht.

    Code
    Mit folgenden Angaben:<br>
    Einberufung:<br>
    Dienststellung:<br>
    Dienstgrad:<br>
    Ausbildung:<br>
    Ausbildungsort:<br>
    Standort:<br>
    Heimgang:</p>
    <br>
    Als Helfer/Besucher eine kurze Vorstellung zu deiner Person und den Grund deiner Registrierung.<br>
  • Hallo und ein schön Sonntag Nachmittag, ich muss darauf hinweisen das es in jedem Beitrag erscheint, daher habe ich die Entwickler der Erweiterungen aufgeführt.

    Es hat nichts (doch?) mit der Beitragsvorlage zu tun. Das war als Beispiel aufgeführt, das es verstanden wird was mein benutzen des Editors passiert.


    • Steht initial bereits etwas im Editor, wenn man in exakt dem Forum ein neues Thema starten will?
    • Falls Nein, wurde die Auflistung der Informationen (Einberufung, Dienstgrad, etc.) aus der Zwischenablage eingefügt?
    • Falls Nein, wurde der Beitrag vollständig von Hand verfasst? Welcher Browser- und Version kommt dabei zum Einsatz?
    • Ist das Problem grundsätzlich reproduzierbar oder tritt es nur bei manchen Benutzern auf?


    Deswegen muss Du deine Fragen bitte anders stellen, um eine Lösung zu finden was passiert in der Forensoftware das es zu "Geister"....

    Update 1.1.2019 -> Editor fehler

    kommt.


    Grüße und Danke


    Ergänzung:

    1. Erstelle ich im ACP eine Vorlage kommt es zu keinem Fehler im Editor/Ansicht.

    2. Ergänze ich im Thema diese Vorlage, kommt es zu den <br> ....


    Es muss also eine Erweiterung sein, die den Editor nutzt?

    Freundliche Grüße HSE24 & onel01

    Edited 2 times, last by HSE24 ().

    • Official Post

    Ergänzung:


    1. Erstelle ich im ACP eine Vorlage kommt es zu keinem Fehler im Editor/Ansicht.

    2. Ergänze ich im Thema diese Vorlage, kommt es zu den <br> ....

    Was steht im Quellcode des Editors, wenn die Vorlage drin steht, aber noch nichts geändert wurde? Ich bitte um das vollständige, unbearbeitete HTML.

  • mich verwundert das HTML des Beitrags, wieso steht dort vor dem </p> jeweils ein <br>?

    Das fügt der Editor automatisch ein und wird je nach verwendetem Browser fortgeführt.


    Eingabe im Editor:

    1

    2

    3



    Ausgabe im Quellcode:

    Code
    <p>1</p>
    <p>2</p>
    <p>3<br></p>


    Ich habe mal einen Beitrag angefügt zum Anschauen im Dashboard

    Im Beitrag keine Umbrüche, im Quellcode Umbrüche, im Dashboard Ansicht mit Umbrüchen

    Edited 2 times, last by Quitter ().

  • Hallo, ich hoffe Du kannst mit meiner Antwort etwas anfangen und verstehst es.

    Was steht im Quellcode des Editors, wenn die Vorlage drin steht, aber noch nichts geändert wurde? Ich bitte um das vollständige, unbearbeitete HTML.

    Das ist die Vorlage im ACP:

    Code
    <p>Mit folgenden Angaben:</p>
    <p>Einberufung:</p>
    <p>Dienststellung:</p>
    <p>Dienstgrad:</p>
    <p>Ausbildung:</p>
    <p>Ausbildungsort:</p>
    <p>Standort:</p>
    <p>Heimgang:</p>
    <p><br></p>
    <p>Als Helfer/Besucher eine kurze Vorstellung zu deiner Person und den Grund deiner Registrierung.</p>

    Im Thema angezeigte Vorlage.

    Vom System wird der erste Satz (Ansprechen) und der letzte Satz (Grüße) erzeugt:

    Es kommt zu dieser Ansicht beim öffnen mit dem Quellcode:

    Im Quellcode kommt es zu diesen Zusätzlichen Zeichen:  <br> ;  <strong> / </strong>  

    In der Vorlage ist es nur das <p> und </p>. wie es auch sein sollte und ist.


    Ich hoffe wir finden die Ursache bzw. die Erweiterung im System die diese "geister " erzeugt.

    Danke

    Freundliche Grüße HSE24 & onel01

    • Official Post

    Hallo,


    ich bin etwas hinsichtlich des Fettdruck (<strong>…</strong>) irritiert, dieser ist laut eigenen Angaben in der ursprünglichen Vorlage nicht vorhanden, aber wieso sollte der Bot hier etwas hinzufügen. Das ist für mich alles nicht schlüssig, irgendwie werde ich den Verdacht nicht los, dass hier ein Puzzle-Teil fehlt.


    Bitte wende dich per Ticket an uns, damit ich mir das Problem direkt mal in der betroffenen Installation ansehen kann.