Zitat von User nochmal zitieren

  • Affected Version
    WoltLab Suite 5.5
    Affected App
    WoltLab Suite Forum

    Hallo,


    Ich habe in meinem Forum einen Beitrag eines Users zitiert, diesen Beitrag von mir (mit dem Zitat von dem anderen Beitrag des Users) wollte ich eben zitieren (Also meinen Beitrag indem ich den anderen Beitrag des Users zitiert habe), jedoch erhalte ich dann folgende Fehlermeldung:


    Requested URL
    POST /forum/index.php?ajax-proxy/&t=3af5a807ddb7c172d38b0282a60ba81737e0908249921d6243e074b22f6391b0-k3bDaJuX/jQSp5k65vnbRw==
    Referrer
    https://example.de/forum/thread/9-was-hast-du-heute-gemacht/?postID=392
    Error Message
    Undefined property: DOMElement::$childElementCount
    Type
    wcf\system\exception\ErrorException
    File (Line)
    /var/www/clients/client0/web1/web/lib/system/WCF.class.php (341)
    Stacktrace
    1. /var/www/clients/client0/web1/web/lib/system/html/input/node/HtmlInputNodeProcessor.class.php (322): wcf\system\WCF::handleError(…)
    2. /var/www/clients/client0/web1/web/lib/system/html/input/HtmlInputProcessor.class.php (190): wcf\system\html\input\node\HtmlInputNodeProcessor->enforceQuoteDepth(…)
    3. /var/www/clients/client0/web1/web/lib/system/message/quote/MessageQuoteManager.class.php (148): wcf\system\html\input\HtmlInputProcessor->enforceQuoteDepth(…)
    4. /var/www/clients/client0/web1/web/forum/lib/data/post/PostAction.class.php (3056): wcf\system\message\quote\MessageQuoteManager->addQuote(…)
    5. /var/www/clients/client0/web1/web/lib/data/AbstractDatabaseObjectAction.class.php (216): wbb\data\post\PostAction->saveFullQuote(…)
    6. /var/www/clients/client0/web1/web/lib/action/AJAXProxyAction.class.php (92): wcf\data\AbstractDatabaseObjectAction->executeAction(…)
    7. /var/www/clients/client0/web1/web/lib/action/AJAXInvokeAction.class.php (111): wcf\action\AJAXProxyAction->invoke(…)
    8. /var/www/clients/client0/web1/web/lib/action/AbstractAction.class.php (57): wcf\action\AJAXInvokeAction->execute(…)
    9. /var/www/clients/client0/web1/web/lib/action/AJAXInvokeAction.class.php (65): wcf\action\AbstractAction->__run(…)
    10. /var/www/clients/client0/web1/web/lib/system/request/Request.class.php (90): wcf\action\AJAXInvokeAction->__run(…)
    11. /var/www/clients/client0/web1/web/lib/system/request/RequestHandler.class.php (107): wcf\system\request\Request->execute(…)
    12. /var/www/clients/client0/web1/web/forum/index.php (11): wcf\system\request\RequestHandler->handle(…)
    • Official Post

    Hallo,


    der Fehler wird mit dem nächsten Update behoben sein. Als Sofortlösung (und generelle Empfehlung!) für WoltLab Suite 5.5 sollte auf PHP 8.1 (alternativ: 8.0) umgestellt werden.

  • Die Frage ist, ob auch alles Plugins im Store die für 5.5 Freigegeben sind, auch PHP 8.1 unterstützen?


    Werden Plugins für die 5.5 von euch auf Unterstützung von PHP 8.1 geprüft? Wenn ja, werde ich auf 8.1 umstellen

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!