Welche Versionen bei Lizenzerweiterung ?

  • Hallo,


    zur Zeit läuft bei mir
    WoltLab Suite Core 3.0.27

    WoltLab Suite Forum (Burning Board) 5.0.25


    Wenn ich jetzt meine Lizenz für 54,99 € erweitere, welche Versionen habe ich dann?

    Die jeweils aktuellsten, also WoltLab Suite 5.5 und das aktuellste Forum ?


    Geht das Update von 3.0.x auf 5.5 auf einen Schritt oder muss ich da viele Zwischenschritte machen (auf 4, auf 5, auf 5.x usw.) ???


    • Official Post

    Hallo,


    bei der Erweiterung erhält man automatisch Zugriff auf die aktuellste Version, aktuell ist dies 5.4. Die Version 5.5 wird wahrscheinlich noch in diesem Monat erscheinen und wird ebenfalls inklusive sein.


    Das Upgrade läuft über die Zwischenschritte über die WoltLab Suite 3.1, 5.2, 5.3 und 5.4. Die einzelnen Upgrades sind in unserem Handbuch erläutert: https://manual.woltlab.com/de/updates/.

  • Wenn ich eine komplette Neuinstallation von der WoltLab Suite 5.x durchführe.

    Kann ich dann die Daten (User, Foren, Beiträge usw.) direkt vom WCS 3.0.27 und vom WBB 5.0.25 importieren ?

    • Official Post

    Eine Neuinstallation ist nicht notwendig und es empfiehlt sich ein schrittweises Upgrade, der Arbeitsaufwand ist in etwa vergleichbar. Ansonsten ist natürlich auch eine Neuinstallation (sinnvollerweise direkt mit 5.5) und anschließendem Import möglich, die Anleitung dazu findet sich in unserem Handbuch: https://manual.woltlab.com/de/migration/.

  • Ich habe jetzt die Lizenzerweiterung gekauft.
    Habe aber so meine Probleme mit dem Update im ersten Zwischenschritt zu 3.1.


    Wenn das Update von 3.0.x auf 3.1.29 starte bekomme ich eine ganze Liste von Paketen aufgeführt die eine Aktualisierung verhindern würde.

    Ich nehme jetzt mal an ich muss für diese Pakete auch noch eine neuere Lizenz erwerben oder einfach noch den richtigen Update-Server eintragen.


    Wo ich aber nicht weiterkomme ist.

    Beim Forum wird ein Update auf 5.1.25 vorgeschlagen, das ist auch die einzige Auswahlmöglichkeit.



    Wenn ich aber das Update starten will bekomme ich die Fehlermeldung:

    An update of package com.woltlab.wbb from version 5.0.25 to 5.2.0 is not supported.


    Von 5.2.0 ist aber gar nichts angegeben.

    Diese Fehlermeldung bekomme ich allerdings auch wenn ich das Update des Forums deaktiviere (Häckchen weg)



    Was ist zu tun?

  • Vielen Dank für die schnelle Antwort, wie gesagt habe ich die Updateserver für 5.x nun deaktiviert, jetzt komme ich an dieser Hürde vorbei.


    Jetzt habe ich das selbe Problem aber mit meinem Stil "Metro" von CLS-Design. Im Forum da habe ich noch keine Antwort bekommen.


    (keine andere Auswahl möglich)


    Dann bekomme ich aber die Fehlermeldung:

    An update of package com.cls-design.wcf.style.metro from version 3.0.0 to 3.1.0 is not supported


    Da frage ich mich warum obwohl auf 3.1.1. updatet werden soll in der Fehlermeldung dann 3.1.0 steht.
    Allerdings hat "Metro" noch drei abhängige Pakete, vielleicht liegt es ja an diesen.


    Wenn ich umgekehrt zuerst nur das WS 3.0 auf 3.1 updaten will, ohne das Metro gleich mit zu updaten, bekomme ich die Fehlermeldung dass Metro 3.0 ein Update verhindern würde.


    Wo ist der Fehler oder was mache ich falsch ?

    • New
    • Official Post

    Hallo,


    bei Upgrades werden auch implizit Zwischenversionen installiert. Es wird somit 3.1.1 angeboten, aber implizit erfolgt ein Zwischenschritt über 3.1.0, da kein direktes Upgrade auf 3.1.1 möglich ist. Eventuell ist die Information auch fehlerhaft und es wird gar kein Upgrade auf die Version 3.1.x des Stils unterstützt, in dem Fall ist der Stilersteller der richtige Ansprechpartner.

  • Mit dem Update von 3.0 auf 3.1 habe ich bisher nur Probleme. Einige Plugins lassen sich nicht direkt updaten und müssten deinstalliert und nach dem Update auf 5.4 sowieso wieder neu installiert werden.

    Inzwischen bin ich eher dafür eine komplett neue Installation vom 5.4 zu machen, und meine Plugins dann auch alle neu zu installieren.


    Ansonsten ist natürlich auch eine Neuinstallation (sinnvollerweise direkt mit 5.5) und anschließendem Import möglich,


    Daher will ich nochmal fragen um sicher zu gehen.


    Ich kann bei einer Neuinstallation von 5.4 alle Daten (User, Beiträge, Foren- und Unterforen, Benutzerrechte usw.) DIREKT per Datenimporter vom 3.0.27 (WBB 5.0.25) ins 5.4 importieren ??


    In der Liste https://manual.woltlab.com/de/migration-sources/ sind nur
    Burning Board 2.3.x
    Burning Board 3.x / Lite 2.1.x

    Burning Board 4.x / WoltLab Suite 5.x


    aufgelistet.


    Auf der Seite Downloads geht der Dateiimporter auch nur runter bis zu 3.1.x

    Edited once, last by Martin-LF ().

    • New
    • Official Post

    Ich kann bei einer Neuinstallation von 5.4 alle Daten (User, Beiträge, Foren- und Unterforen, Benutzerrechte usw.) DIREKT per Datenimporter vom 3.0.27 (WBB 5.0.25) ins 5.4 importieren ??

    Ja, korrekt. Aber da hier mehrfach die Rede von 5.4 ist: Bitte installiere direkt die Version 5.5, sonst müsste von 5.4 auf 5.5 direkt wieder ein Upgrade stattfinden.


    Auf der Seite Downloads geht der Dateiimporter auch nur runter bis zu 3.1.x

    Die Version des Importers hat nichts mit der Quellversion zu tun. Der Neuinstallation von 5.5 liegt der Importer bereits als optionale Paket bei und wird im Verlauf der Installation automatisch angeboten.


    Daher: Einfach die Version 5.5 installieren und den währenddessen angebotenen Importer mit installieren. Falls neben dem Forum noch andere Apps zum Einsatz kamen: Erst die Apps installieren und dann den Import starten. Als Datenquelle „Burning Board 4.x, WoltLab Suite Forum 5.x“ auswählen und den Rest der Anleitung befolgen: https://manual.woltlab.com/de/…hfuhrung-des-datenimports

  • Nachdem nun ein anderes Problem (Link) gelöst zu sein scheint, werde ich es doch nochmals mit den schrittweisen Updates versuchen.


    Aber da hier mehrfach die Rede von 5.4 ist: Bitte installiere direkt die Version 5.5,


    Ich wollte nur bis 5.4 weil es für, ein mir wichtiges Plugin, noch keine Version fürs 5.5 gibt, sondern nur bis 5.4
    Habe jetzt aber gesehen das 5.4 auch nur bis PHP 8.0 funktioniert (ich meine bis vor kurzem stand da auch noch PHP 8.1), mein Hoster aber im November nur noch 8.1 anbietet. Daher jetzt doch 5.5

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!