WoltLab Suite 5.5 Beta

    • Official Post

    We are proud to announce the first public beta of WoltLab Suite 5.5. Continuing the successful version 5.4 and featuring many sophisticated improvements and useful new features, this version once again delivers the best possible experience for your community.

    System Requirements

    WoltLab Suite 5.5 requires the following prerequisites to install and run the software:

    • Webserver with PHP 7.4 or newer (PHP 8.1 recommended) *
    • MySQL 5.7.31 or newer / MySQL 8.0.19 or newer / MariaDB 10.1.44 or newer
    • Current Webbrowser

    * PHP 7.2.24+ and PHP 7.3 are sufficient to install the software, but are not officially supported.

    Installation Guide

    1. Download the installation archive onto your computer.
    2. Extract the archive.
    3. Upload the files install.php, test.php and WCFSetup.tar.gz onto your webserver.
    4. Start the installation by navigating with your webbrowser to the test.php.

    Updating from earlier versions

    The first beta version explicitly does not support updating from previous versions of our software. Update support will be added with future releases.

    Usage and Support

    This evaluation version is not suitable for use in production environments, doing so is entirely at your own risk. An update from WoltLab Suite 5.5 Beta 1 to future versions is not guaranteed. You may use these apps for free until July 10th, 2022, if you would like to continue using this software past this date, you'll have to own a valid product license.


    We're looking forward to hear your feedback and report of possible issues in this forum.



    The pre-release versions are available for download in the customer area for all customers with active licenses.

  • Alexander Ebert

    Changed the title of the thread from “WoltLab Suite 5.5 Beta 1” to “WoltLab Suite 5.5 Beta”.
    • Official Post

    The release Beta 3 is now available and addresses multiple issues found in the previous version.


    Customers can update from Beta 1 and Beta 2 directly through the admin panel. Please navigate to the package list and click on “Search for Updates” to initiate this process.

    • Official Post

    Version Beta 4 is now available, this is the last beta version before entering the RC phase. Upgrade from WoltLab Suite 5.4 is supported starting with version RC 1.

    Important Changes in Version Beta 4

    • The dialog to start a new thread provides a much more user friendly and clean list of the selectable forums.
    • The color picker has been redesigned from the ground up and offers an easy and comfortable experience to pick colors.
    • The feature to manage ignored forums has been reworked, forums are now ignored by ticking the checkbox instead.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!