ACP Ajax-Fehler "unschön"

  • Affected Version
    WoltLab Suite 5.4

    Ich meine, das Problem betrifft auch ältere Versionen, aber bin mir da gerade nicht sicher. Aufgefallen ist es mir jedenfalls zufällig in 5.4:




    Im vorliegenden Fall hatte ich die Paket-Übersicht 2x offen, ein Paket im ersten Tab deinstalliert und irgendwann später im 2. Tab das selbe Paket noch einmal deinstallieren wollen, was logischerweise nicht mehr ging. Die Fehlermeldung selbst ist also korrekt, nur die Darstellung offensichtlich nicht.

    • Official Post

    Hallo,

    Ich meine, das Problem betrifft auch ältere Versionen, aber bin mir da gerade nicht sicher.

    Ja, betrifft mindestens auch 5.3.x.


    Halbwegs relevant ist diese Issue auf GitHub, in Zuge derer man das auf jeden Fall einmal prüfen sollte:


    Clean Up Exception Handling · Issue #4342 · WoltLab/WCF
    The current handling Exceptions is historically grown and suffers from quite a few issues. Among these are unreadable god methods in core.functions.php,…
    github.com

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!