Eigene Grafiken als Forum-Icons

  • Hey zusammen,

    ich versuche seit gestern meine Foren Icon umzuändern, um eigene Grafiken zu verwenden.

    Bislang hatte das vor der 6.0 Version mittels Code geklappt, aber nun funktioniert es nicht mehr.

    Folgender Code wurde verwendet:

    Code
    .wbbBoardList .wbbBoardContainer.wbbDepth2[data-board-id="2"] > .wbbBoard > .icon32:before {
       background-image: url(.../images/Name);
       content: "";
       background-size: 45px;
       display: block;
       width: 45px;
       height: 45px;
       margin-right: 20px;
    }


    Hat jemand eine Idee, warum die Icons sich nicht ändern lassen?

  • Kann man die Icons nicht anderweitig ändern, um eigene Grafiken zu nutzen?

    So geht es, ob es besser geht kann möglich sein.

    Habe die Grafik über den Stil hoch geladen.

    Mit den Werten kannst du ja spielen, bis es für dich passt.

  • So geht es, ob es besser geht kann möglich sein.

    Habe die Grafik über den Stil hoch geladen.

    Mit den Werten kannst du ja spielen, bis es für dich passt.


    Ich habe den Code genauso ausprobiert, aber die Icons bleiben unverändert. :/

  • Genauso wird nichts werden, du musst schon einen Grafik angeben und deine eigene BoardID.

    Dann hab ich mich unglücklich ausgedrückt.
    Den Code hab ich natürlich angepasst und den Pfad zu meiner Grafik angegeben. Beispiel: /images/icon1.png

    Oder ist der Pfad nicht korrekt?

  • Bei mir funzt dieses (Größe der Grafik vorher entsprechend angepasst):

    Für gelesene Inhalte

    Code
    li[data-board-id=""] .wbbBoard .fa-folder-open-o::before{
        content:url("../icon/link-zur-grafik");
    }

    Für ungelesene Inhalte

    Code
    li[data-board-id=""] .wbbBoard .fa-folder-open::before{
         content:url("../icon/link-zur-grafik");
    }

    Ich nutze noch kein 6.0 ;) Aber vielleich funzt es damit ja auch dort :thumbup:

  • Kann mir jemand sagen, wie ich alle Foren-Icons auf einmal ändern kann? Ich habe bisher wohl ein altes Fontawesome Icon genutzt und jetzt zerschießt es mir die Seite nach dem Update?

    Code
    Error Message:
    The icon 'map-marker' is unknown.
    Error Type:
    wcf\system\style\exception\UnknownIcon
    */lib/util/ScFontAwesomeIconMetadata.class.php:46

    Also schnell alle Icons der Foren ändern ohne in jedes (ca. 80 Foren) einzeln reingehen zu müssen?

  • Bei mir funzt dieses (Größe der Grafik vorher entsprechend angepasst):

    Für gelesene Inhalte

    Code
    li[data-board-id=""] .wbbBoard .fa-folder-open-o::before{
        content:url("../icon/link-zur-grafik");
    }

    Für ungelesene Inhalte

    Code
    li[data-board-id=""] .wbbBoard .fa-folder-open::before{
         content:url("../icon/link-zur-grafik");
    }

    Ich nutze noch kein 6.0 ;) Aber vielleich funzt es damit ja auch dort :thumbup:


    Hat leider bei mir auch nicht funktioniert, aber ich hab momentan sowieso kleine Schwierigkeiten mit meinem Design.
    Vor der 6.0 Version hat es ohne Probleme geklappt :/

  • Das Problem hat sich nun gelöst. Nochmal lieben Dank an den mipu für die Hilfe.

  • Hab sowas gerade mal zum Spaß mit dem obigen Code ausprobiert, und das funktioniert tatsächlich auf Anhieb.

    Allerdings nur auf der Ebene der unmittelbar übergeordneten Kategorie, auf den Ebenen darüber nicht (da wird dann das default_icon angezeigt). Gibt’s dafür auch ’ne universelle Lösung (also dass es auf allen Ebenen funktioniert, egal wie tief verschachtelt sich das Forum befindet)?

    Edited once, last by DEG 1935 (April 21, 2024 at 5:31 AM).

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!