Uploading images to articles is not working

  • Affected App
    WoltLab Suite Core

    Tried two different ways of doing this.

    One; trying to upload an image using the upload button for article and get this displayed when trying to upload a small avatar image.


    Second; is using upload MEDIA option instead included in Redactor editor and it lets me upload an image as show below.

    But then when I try and insert the image into editor it shows this.

  • The image was my avatar used here. I also tried it before using other images like a small JPG cover image of a movie and that didn't work either. I have picked to use ImageMagick and not GD in settings if that matters, but ImageMagick is installed.

    Just tested it now using GD instead and same problem. I cannot uploaded any image if using the big Article upload image button. The only way I can upload an image is by using upload MEDIA button in Redactor and that will upload the image, but then it never shows up if inserted into editor (just shows as broken image) and even if saved and look at article it doesn't show any image inserted into it reading on front-end. Also, If I use the MEDIA upload small button in Redactor to upload the image. Then switch and click the big upload Artcle image button - it's lists the image as there to pick but again will just show a broken image if picked as cover article

    To be honest it's always been this way for me testing WBB Suite and just thought it was Work In Progress not added as a feature yet in Alpha

    • Official Post

    I have no problem uploading either of the attached images.

    Regarding the insertion issue: That also works for me locally and this issue (or at least a similar issue) has been fixed by me some time ago. Please make sure, when posting issues regarding the ACP that you use the latest version.

  • The version I'm using was installed late last night after you stopped doing any more fixes for the day.

    I don't see any fixes made with attachments listed since today? But I'll do a clean install later tonight and see if same problem is there after you've finished doing today's fixes again and the download is updated with them. As even clicking "MEDIA" button to get on Media Page doesn't let me upload anything to there either.

    If the problem still happens later I'll give you admin login to the site to see for yourself testing

  • Just downloaded and installed latest version from here, I think it gets updated every 15 minutes: https://support.softcreatr.de/wcf-download/

    Tested and same problem. I have created another admin account and you can login and look for yourself testing it, I'll send you PM for account details to login with in a second.

    Try with different sized images because noticed before it will let me upload the small movie JPG image via MEDIA page - but when I try and upload another larger image it fails. So seems to work for one image (a small one) and not others uploading. So a bit hit and miss, you need try and few images of different sizes

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!