Frage vor PHP Update

  • Hi,


    ich habe seit ca 4-5 Jahren ein Forum im Betrieb welches ich auch Softwaretechnisch nicht aktualisieren möchte, weil es halt einfach gut läuft und ich damals auch viel Arbeit mit Plugins usw investiert habe.


    Die WBB Version ist die 3.1.8 und ich habe die PHP Version 5.2.17 aktiv.


    Mein Provider 1&1 verlangt nun seit einiger Zeit monatlich ca 5 € extra weil ich eine veraltete PHP Version nutze.
    Um diese Kosten wieder einzusparen kann ich wechseln auf PHP 5.5, 5.6 und 7.0, wobei mir 5.6 empfohlen wird.


    Kann ich jetzt ohne Bedenken auf die 5.6 wechseln, oder kann es passieren, dass dann plötzlich irgendwas nicht mehr funktioniert?
    Habe mich praktisch seit Jahren nichtmehr mit der ganzen technischen Geschichte befasst und moderiere lediglich weiterhin das Forum.
    Aus dem Grund bin ich auch etwas panisch das Upgrade durchzuführen.


    Was meint ihr?


    Vielen Dank im Voraus!


    mfg

  • kann es passieren, dass dann plötzlich irgendwas nicht mehr funktioniert?


    Die WoltLab-Software selbst funktioniert auch noch unter 5.6. Jedoch kann es Probleme mit Drittanbieter-Erweiterungen geben.

  • Vielen Dank für die schnelle Antwort!


    Also wäre es vermutlich sinnvoll eher auf die 5.5 zu wechseln, weil es dann am wahrscheinlichsten ist, dass alle Plugins noch laufen?


    Könnte ich über diese htaccess Geschichte auch jederzeit zurückwechseln, falls wichtige Plugins nicht mehr funktionieren sollten?


    mfg

  • Also wäre es vermutlich sinnvoll eher auf die 5.5 zu wechseln

    Wäre sinnvoller.

    Könnte ich über diese htaccess Geschichte auch jederzeit zurückwechseln, falls wichtige Plugins nicht mehr funktionieren sollten?

    Das kann ich Dir nicht sagen. Das müsstest Du bei deinem Hoster nachfragen.


    Ps. Das ist schön wenn es Problemlos laufen tut :)

  • Ich schreib 1&1 mal an ob man auch wieder zurück auf die 5.2er Version wechseln kann falls die 5.6er nicht so läuft wie man sich das wünscht.


    Die 5.5er macht auch nicht wirklich Sinn, weil man ab Anfang 2017 auch mit der Version draufzahlen müsste -.- Bei 5.6 ist bis 2019 alles safe.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!