[2.0] Diverse Probleme mit Microsoft Edge und dem Editor

  • Affected App
    WoltLab Suite Core

    Ich zitiere hier einfach mal meine User:


    Quote

    seit ich Microsoft Edge benutze kann ich im Forum-Editor kein Strg+V mehr verwenden.

    Quote

    Ich habe genau das gleiche Problem mit Microsoft Edge. Auch springt er manchmal einfach nach vorne beim Schreiben, was sehr ärgerlich ist, da er mir dann alles verhunzt

    Quote

    Ich möchte melden, dass ich mit meinem Internetbrowser Microsoft Edge einige Probleme im Forum habe wie z.B:
    -ich kann nichts einfügen
    -die meisten Buttons(z.B VB.NET Quellcode) funktionieren nicht
    - ich kann keine Smileys einfügen

  • Ich verwende die neueste Version, also 2.0.13.


    Ich dachte eigentlich, bei der Erkennung ging es nur um die korrekte Bezeichnung in der Online-Liste.


    Wie auch immer, der Bug ist da. ;)

  • Nicht verwunderlich. Im WCF 2.0 kommt noch der CKEditor 4.3.2 zum Einsatz. Der CKEditor im WCF 2.0 wurde vor bald zwei Jahren (!) zuletzt aktualisiert. Die Edge-Kompatibilität kam logischerweise erst sehr viel später in den CKEditor. Genauer im CKEditor 4.5 gab es die erste offizielle Unterstützung für Edge.

    • Official Post

    Ein Upgrade der CKEditor auf Version 4.5 wird es von unserer Seite aus nicht geben. Grundsätzlich scheint alles weiterhin zu funktionieren, aber wir können die einwandfreie Funktionsweise nicht garantieren und die Auswirkungen auf Plugins von Drittanbietern ist nicht absehbar. Sollte eine native Unterstützung von Microsoft Edge gewünscht sein, empfehlen wir ein Upgrade auf Burning Board 4.1.


    --


    Wer dennoch auf eine Unterstützung von Microsoft Edge in Burning Board 4.0 wert legt, kann manuell eine Aktualisierung des CKEditor auf Version 4.5 vornehmen. Dies erfolgt ausdrücklich auf eigene Gefahr und wir bieten bei Problemen explizit keine Unterstützung:
    Das Installationspaket kann direkt von ckeditor.com heruntergeladen werden und muss in das Verzeichnis wcf/js/3rdParty/ckeditor/ entpackt werden. Alle bestehenden Dateien müssen dazu (falls zutreffend) ersetzt werden.


    Edit: Bitte das "Full Package" verwenden. Ich habe nur Version 4.5.5 getestet, es sollten auch nachfolgende Versionen der 4.5er Reihe möglich sein. Höhere Versionen gibt es zu diesem Zeitpunkt nicht und wurden dementsprechend nicht getestet.

  • Bei einem Update eurerseits würde das ja verloren gehen - wieso kommt da nicht die neue Version des Editors rein, wie bei Redactor und WCF 2.1 auch?

  • wieso kommt da nicht die neue Version des Editors rein


    Grundsätzlich scheint alles weiterhin zu funktionieren, aber wir können die einwandfreie Funktionsweise nicht garantieren


    Ist das nicht Begründung genug?





    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier.

  • Ich habe den Editor in meinem WCF 2.0 soeben von 4.3.2 (wenn die Angabe in der CHANGES.md stimmt) auf 4.5.6 aktualisiert und konnte bisher keine Fehler feststellen. Zumindest keine neuen, was mit den alten ist, wird sich zeigen.


    EDIT: Auch eine Woche später sind keine Probleme aufgetreten. Leider halten sich meine User mit Feedback zurück, was die Edge-Kompatibilität angeht... ;)


    EDIT #2: Leider zu früh gefreut: Nach CKEditor-Update: Beim Einfügen von Text in Chrome wird HTML erzeugt


    EDIT #3: Achtung! Version 4.4.8 ist die neueste, die noch kompatibel ist! Alles ab 4.5.0 klappt nicht im WCF 2.0!


    EDIT #4: Vergesst das Editor-Update! Auch die 4.4.8 macht Probleme. Opera 12.x klappt gar nicht mehr und in Chrome sorgt ein HTML-Code im Posting dafür, dass man keine Vorschau mehr sehen kann (stattdessen wird dann gepostet).

    Edited 5 times, last by King555 ().

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!