"Es sind Aktualisierungen für installierte Pakete verfügbar" ausblenden, aber wie?

  • Hallo,


    ich habe für mein Forum diverse Exklusiv Plugins installiert. Einige erlauben es mir nicht, Aktualisierungen vorzunehmen. Daher taucht bei neuen Updates der Hinweis in der Blauen Info Box: "Es sind Aktualisierungen für installierte Pakete verfügbar" auf. Ich würde diesen gerne ausblenden lassen. In den Einstellungen wurde ich nicht fündig, so dass ich mir nun eine entsprechende CSS Deklaration wünsche. Könnte mir jemand helfen?




    lg

  • Das dürfte mit CSS nicht funktionieren, da Du dann alle Anzeigen der Klasse .info ausblenden würdest. Du kannst allenfalls den Hinweis direkt aus dem Template userNotice entfernen.





    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier.

  • In diesem Besonderen Fall, würde ich einfach die Entsprechenden "Update-Server" im ACP Ausblenden.


    Diese kann man bei Bedarf jeder Zeit wieder Einblenden.
    :thumbup:

    Mit Besten Grüßen, ArnoEdwin.      Einige die mich kennen, Mögen mich. Die welche mich nicht Mögen, können mich!

  • Ich habe leider das selbe Problem, betrifft ein Plugin das ein Update für wbb 4.1 hat udn ich habe wbb 4.0 Würde ich nun den Server rausnehmen dann würden mir aber alle anderen Plugins von hier auch nicht mehr angezeigt werden. Darum finde ich diese Lösung nicht so gut. Fragte auch beim Pluginersteller schon nach ob ich diese Meldung weg kriegen kann, er meinte geht nicht. Also muss ich damit leben oder jedes einzelne Plugin das ich über Pluginstore runtergeladen habe immer wieder neu Anklicken und schauen ob es ein Update gibt, was zuviel Arbeit macht wenn man viele Plugins von Pluginstore hat.


    Von daher wäre es gut wenn es eine andere Lösung gäbe aber ich vermute das es die nicht gibt und darum muss ich und der Admin meines Forums eben damit Leben das die Anzeige nun immer da ist.

  • ok danke für den Tipp aber da werde ich persönlich nichts dran machen. Bin nicht so versiert was Datenbank betrifft.

  • Vieleicht hilft das hier.
    Leider sieht man die Meldung solange die Seite geladen wird. Danach verschindet sie aber.


    Ist eine abgewandelte Version von https://pluginstore.woltlab.com/file/1488/, wo kein Menüounkt erstellt wird.

  • danke dir für den Tipp. Das angehängte Plugin ist noch in Beta wie ich beim Hochladen sehen konnte.
    Da ich schon schlechte Erfahrungen mit Beta Plugins machte, stellt sich mir die Frage, wie sicher ist dieses Plugin? Beta Plugins normal noch nicht ganz ausgreift, nicht genug getestet, etc und dann könnte es Probleme geben.
    Ich meine das nun nicht böse, noch weniger will ich dir unterstellen das du nichts gutes hinkriegst. Geht mir nur um die Funktion ob es da Probleme geben könnte.
    Im Testboard geht es ohne Probleme, habe es aber eben erst da hochgeladen.

  • Du kannst es nehmen...Es besteht kein Risiko.
    Es ist deshalb in Beta, weil es vielleicht eine bessere Variante gibt.
    Während die Seite läd, sieht man ja die Meldung.


    Der code ist von @rs90. Sein Plugin steht schon seit einem Jahr im App-Store und wird fleißig genutzt.

  • Danke dir für deine Antwort. Dann werde ich das heute im Forum einsetzen, denn nun gab es von einer anderen Seite schon wieder eine Update Meldung für ein Plugin welche aber nur bei WBB 4.1 geht nicht bei 4.0
    Verstehe nicht warum das nun plötzlich so losgeht, war bisher nicht so das mir im Forum und ACP Updates für das 4.1 angezeigt werden. Die bringen ja nichts wenn man WBB 4.0 hat ausser das es eine Fehlermeldung gibt oder die Meldung das dies bei der Version nicht geht.

  • Gegen Frage


    Wusstest du schon das auch Admins, übriegens auch nur Menschen, sich nerven, wenn immer mehr Updatemeldungen kommen die für andere WBB Version sind und nichts mit der Version zu tun haben die man selber hat?


    In der Meldung im Forum steht nur das Update da ist, keine Version, keine weitere Meldung, also geht jeder Admin logischerweise in ACP und will das Update durchführen, mit dem Resultat das alles für die Katze ist. Weil die neue Meldung, nur wieder ein WBB4.1 Update im WBB 4.0 zeigt! Ein Support oder Plugin Forum oder wie auch immer es nennen willst ist da Spezialist dafür. Sammle grad WBB 4.1 Updates von denen und wenn man es meldet heisst es nur da kann ich nix machen, musst damit leben. Bei anderen Foren, gibt es da keine Probleme, diverse Leute haben WBB 4.0 Plugins gemacht und dann auf WBB 4.1 erweitert, von denen kriege ich keine Meldung für Update da es richtig läuft.

  • wusstet ihr schon....




    .. dass diese Updatemeldungen ohnehin nur die Admins sehen können?


    Das wissen sicher die meisten. ;) Trotzdem gibt es Situationen, wo man nicht updaten will / kann (Beispiel Inkompatibilitäten etc) und dann nervt eine Meldung, die man nicht ausblenden kann (ohne die Paketserver zu deaktivieren). Eine "Gelesen-Funktion" oder "Ausblenden bis / für" wurde ja schon mehrfach angefragt. ;) Auch eine Meldung zu Updates per PN an den Admin-Account wäre eine elegantere Lösung. Da wäre jedenfalls dieser Kasten verschwunden. ;)

  • Ich hab NICHT gesagt, dass es nicht nervt!! ;)


    und auch ich dachte anfangs, dass das jeder sehen kann, dieser Gedanke ist also nicht ganz abwegig ;)


    Bei anderen Foren, gibt es da keine Probleme, diverse Leute haben WBB 4.0 Plugins gemacht und dann auf WBB 4.1 erweitert, von denen kriege ich keine Meldung für Update da es richtig läuft.

    Dann geh doch ausschliesslich zu jenen Foren und "sammel" deine Plugins nur dort ;) Wenn die das besser auf die Reihe bekommen xD :D Dann wirst du von den anderen Foren nicht genervt mit unsinnigen Updatemeldungen ;)



    Wenn was auf den Updateservern neu gemacht wird, erscheint es halt als neu..und wenn jene Foren keinen Updateserver haben, können sie ergo auch nicht rumnerven ;)
    Abhilfe: Schalt die Updateserver zeitweise ab und mach sie halt nur monatlich mal an, damit du deine Updates ziehen kannst und gut ist ...

  • Ihr habt wahrscheinlich die falschen Updateserver drin/aktiv


    Nein, das hat nichts mit dem Updateserver von Woltlab zu tun da funktioniert alles bestens. Geht um einen anderen Updateserver.
    Ich schaue nun welche Plugins von dem einen Ort (Server) ich mit anderen austauschen kann.
    Hab echt die Nase voll, von wegen, da kann man nix machen. Bei Woltlab Server geht es auch dies zu trennen und hier läuft es auch bestens.



    und auch ich dachte anfangs, dass das jeder sehen kann, dieser Gedanke ist also nicht ganz abwegig

    das dachte ich nie, für mich war klar das nur Admins sehen, weil ich mit dem Testaccount öfters als Mitglied in Forum rein ging um Änderungen zu überprüfen, ob sie gehen wie sie sollen.


    Wenn was auf den Updateservern neu gemacht wird, erscheint es halt als neu..und wenn jene Foren keinen Updateserver haben, können sie ergo auch nicht rumnerven

    das ist klar das es Änderungen gibt in Updateservern, aber wenn alles kreuz und quer auf einem Server liegt, dann kriegt eben jeder alle Updates, ob die nun zu seiner Version passen oder nicht.
    Da hat es Woltlab besser gelöst, da kriegt man nur die Updates die zur eigenen Version passen. Was auch beweist das es möglich ist Updates zu trennen, wenn man wirklich will und das es nicht unmöglich ist

    Edited once, last by Leandra ().

  • Bei Woltlab Server geht es auch dies zu trennen und hier läuft es auch bestens.


    Du erwartest doch jetzt nicht, dass jeder Entwickler ggf. mehrere Updateserver bereitstellt, oder? Im Grunde ist bereits der eine Updateserver ein reiner Dienst am Kunden und nun werden wegen dieser von WoltLab ebenfalls als Dienst am Kunden eingeführten Meldung Forderungen aufgestellt, die Pakete bzw. Versionen auch noch auf verschiedene Server zu verteilen? Anders ließe sich das nämlich nicht lösen. Im Extremfall müsste dann für ein einziges Paket ein separater Updateserver betrieben werden.





    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier.

  • naja, so als :


    Ein Support oder Plugin Forum oder wie auch immer es nennen willst

    könnte mans auch ganz einfach lösen und die "veralteten" Versionen eben offline nehmen und gar nix mehr fürs 4.0 anbieten, vll. ist das ja dann lieber? *g*





    Wie gesagt: Ich denke mal, dass die meisten fürs 4.0 nimmer großartige Updates (ausser Sicherheitsupdates) bauen... dann schalte einfach die Updateserver zeitweise aus.. und mach sie nur einmal in der Woche meinetwegen an, wenn du Zeit hast, alles durchzugehen und der Käs ist gefressen... da muss man net wütend werden... die Plugins selbst möchte man aber gerne, gell ;)

  • Ich habe nie gesagt das ich dies so erwarte. Für mich ist es nervtötend und Zeitaufwendig immer vergebens ins ACP zu rennen.


    Darum sagte ich das ich die Plugins austausche!


    Man sollte, wenn dann auch alles lesen, so wie es da steht und nicht nur einen Satz rauspicken und mir damit was in Mund legen das ich so nicht sagte!


    Würde ich erwarten das alle es so machen wie Woltlab hätte ich nicht gesagt das ich mir nun die ganze Arbeit mache, mit Plugins tauschen, welche ich erst überall zusammen suchen muss! Was viel Zeit kostet, da ich nicht jedem Tag mehrere Stunden am PC sitzen oder die ganze Arbeit auf andere abwälzen kann.




    Schön das du, Bibini, als Vollprofis geboren bist, nie klein anfangen musstest. So, hast du natürlich das Recht, uns, die dieses Privileg nicht hatten und zudem nur das WBB 4.0 haben und uns nicht alles kaufen können, zu zeigen wie dumm wir sind.

    Edited 2 times, last by Leandra ().

  • Schön das du, Bibini, als Vollprofis geboren bist, nie klein anfangen musstest. So, hast du natürlich das Recht, uns, die dieses Privileg nicht hatten und zudem nur das WBB 4.0 haben, zu zeigen wie dumm wir sind.


    Ja, genau, und eben WEIL ich ein Vollprofi bin, poste ich sowas hier:


    und auch ich dachte anfangs, dass das jeder sehen kann, dieser Gedanke ist also nicht ganz abwegig


    übrigens, ICH persönlich HABE noch netmal ein eigenes 4.0, sondern führe mein Forum noch mit dem 3.1 ... also spar dir deine gehässigen Sprüche, die immer kommen, wenn du mal Gegenwind bekommst ....und nicht auf dein Mitleidsgeheische ala "ich bin ja soo arm und krank und hatte eine schlechte Kindheit" eingehen .. X/

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!