Fehler Cronjob [Ordnet Benutzer automatisch Benutzergruppen zu]

  • Affected App
    WoltLab Suite Forum

    Hallo,


    Es befindet sich ein Fehler unter Protokoll der ausgeführten Cronjobs:



    Obschon es ein Fehler gibt scheinen die Benutzer richtig in die Benutzergruppe zugeorndet zu werden, eine Fehler unter Protokollierte Fehler gibt es nicht.


    Siehe auch hier:
    Fehler beim Aufruf Cronjob "Ordnet Benutzer automatisch Benutzergruppen zu"


    Bis auf das Plugin ist es das gleiche verhalten.


    Kann sonst jemand das bestätigen?

    ┌П┐(◉_◉)┌П┐

  • Sonst irgendwelche Plugins installiert?
    Seit wann tritt der Fehler auf?
    Seit heute? Gestern?


    Werden generell Fehler geloggt bzw. die entsprechenden txt-Dateien erstellt?


    Bisschen mehr Infos bitte. :)

  • Sonst irgendwelche Plugins installiert?


    Seit wann tritt der Fehler auf?

    Solange die Cronjob-Logs zurückführen :) wann genau keine Ahnung ist mir erst vor kurzem aufgefallen da weder eine Fehlermeldung protokoliert wurden nach irgendwas nicht wie gewollt funktionierte.

    Werden generell Fehler geloggt bzw. die entsprechenden txt-Dateien erstellt?

    Jap werden generell protokoliert und txt-Datei auch erstellt

    ┌П┐(◉_◉)┌П┐

  • So habe mittelerweise rausgefunden dass das Plugin @UdoZ schuld an dem error ist:


    Bug wurde im Forum gemeldet und warte auf einen Fix.

    ┌П┐(◉_◉)┌П┐

  • Also..
    Ich habe das Plugin von @UdoZ in meiner Testumgebung nicht installiert. Bei mir tritt der Fehler auf wenn ich das Spendenplugin von Cwalz installiert habe.


    Vorgang: Testumgebung nur WL Software installiert (sonst nichts)


    - dann eine neue Benutzergruppe erstellt (user erreicht bei xx Punkten diese Gruppe)
    - dann den Cronjob Ordnet Benutzer automatisch Benutzergruppen zu manuell aufgerufen ... alles problemlos
    - dann das Spendenplugin von Cwalz installiert
    - - dann wieder den Cronjob Ordnet Benutzer automatisch Benutzergruppen zu manuell aufgerufen, rums, Fehlermeldung
    =====================
    Hier die Meldung
    =====================
    Wed, 29 Jul 2015 16:40:40 +0000
    Message: Could not execute prepared statement: SQLSTATE[HY000]: General error: 2031
    File: /homepages/14/d407714533/htdocs/test-forum/wcf/lib/system/database/statement/PreparedStatement.class.php (97)
    PHP version: 5.4.42
    WCF version: 2.1.6 (Typhoon)
    Request URI: /acp/index.php?ajax-proxy/&&
    Referrer: http://www.test.forum-blasenkrebs.net/acp/index.php?cronjob-list/&
    User-Agent: Mozilla/5.0 (Windows NT 6.1; rv:39.0) Gecko/20100101 Firefox/39.0
    Information: ""
    Stacktrace:
    #0 /homepages/14/d407714533/htdocs/test-forum/wcf/lib/system/event/listener/DonationUserListener.class.php(33): wcf\system\database\statement\PreparedStatement->execute(Array)
    #1 /homepages/14/d407714533/htdocs/test-forum/wcf/lib/system/event/EventHandler.class.php(221): wcf\system\event\listener\DonationUserListener->execute(Object(wcf\data\user\UserAction), 'wcf\\data\\user\\U...', 'initializeActio...')
    #2 /homepages/14/d407714533/htdocs/test-forum/wcf/lib/data/AbstractDatabaseObjectAction.class.php(148): wcf\system\event\EventHandler->fireAction(Object(wcf\data\user\UserAction), 'initializeActio...')
    #3 /homepages/14/d407714533/htdocs/test-forum/wcf/lib/system/cronjob/UserGroupAssignmentCronjob.class.php(40): wcf\data\AbstractDatabaseObjectAction->__construct(Array, 'addToGroups', Array)
    #4 /homepages/14/d407714533/htdocs/test-forum/wcf/lib/data/cronjob/CronjobAction.class.php(130): wcf\system\cronjob\UserGroupAssignmentCronjob->execute(Object(wcf\data\cronjob\Cronjob))
    #5 [internal function]: wcf\data\cronjob\CronjobAction->execute()
    #6 /homepages/14/d407714533/htdocs/test-forum/wcf/lib/data/AbstractDatabaseObjectAction.class.php(196): call_user_func(Array)
    #7 /homepages/14/d407714533/htdocs/test-forum/wcf/lib/action/AJAXProxyAction.class.php(77): wcf\data\AbstractDatabaseObjectAction->executeAction()
    #8 /homepages/14/d407714533/htdocs/test-forum/wcf/lib/action/AJAXInvokeAction.class.php(96): wcf\action\AJAXProxyAction->invoke()
    #9 /homepages/14/d407714533/htdocs/test-forum/wcf/lib/action/AbstractAction.class.php(49): wcf\action\AJAXInvokeAction->execute()
    #10 /homepages/14/d407714533/htdocs/test-forum/wcf/lib/action/AJAXInvokeAction.class.php(63): wcf\action\AbstractAction->__run()
    #11 /homepages/14/d407714533/htdocs/test-forum/wcf/lib/system/request/Request.class.php(58): wcf\action\AJAXInvokeAction->__run()
    #12 /homepages/14/d407714533/htdocs/test-forum/wcf/lib/system/request/RequestHandler.class.php(139): wcf\system\request\Request->execute()
    #13 /homepages/14/d407714533/htdocs/test-forum/acp/index.php(10): wcf\system\request\RequestHandler->handle('wbb', true)
    #14 {main}


    =================
    Warum äussert sich niemand von WL ???


    Gruß

  • Warum äussert sich niemand von WL ???

    Weil das ein Fehler vom Spendenplugin ist und vom Dritthersteller gefixed werden muss.


    #0 /homepages/14/d407714533/htdocs/test-forum/wcf/lib/system/event/listener/DonationUserListener.class.php(33): wcf\system\database\statement\PreparedStatement->execute(Array)

    Hier tritt der Fehler auf.
    DonationUserListener.class.php


    Sprich du musst dich in Chris Support Forum melden

  • Ob er sich das vorstellen kann oder nicht, fakt ist nunmal dass DonationUserListener.class.php ein Fehler verursacht :)
    Bei mir ist es nur das Plugin von Udo (Pflichtthemen)

    ┌П┐(◉_◉)┌П┐

  • So UdoZ hat das Problem gefixt und ein Update für sein Pflichtthema-Plugin gemacht, es wird die Tage wohl hier im Store auch auftauchen, gibs bei Ihm aber sofort zum Download.


    Werde berichten ob es nun klappt.


    EDIT: Funktioniert nun wie gewollt!

    ┌П┐(◉_◉)┌П┐

    Edited once, last by TeRRible__KHONS ().

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!