Default controllers show up in generated URLs

  • Is it your blog?THen go to my blogs and then the little "edit"
    you can delete the blog then

    Will take look once then. I uninstalled the blog all together on localhost, and reinstalled again fresh, made directory "journals", so it's "localhost/journals/" and it STILL puts that "blog" on end of it. "localhost/journals/blog/" wtf.. how can I get rid of that shit, I didn't want "blog" on there at all. Or is it there regardless, since user blogs are implemented now. But how to remove / mask it on url though? Back to old style of double url names again, which I hated. No point in picking main directory title then either, cause it appends "blog" on end of it anyway. X(


    Back to those old style double names again, domain.com/gallery/gallery/, domain.com/blog/blog/, domain.com/calendar/calendar/ etc. It's fair to assume that calendar and gallery updates will do this same crap again, so I'd rather just save the money and not buy those two updates in future. No point in buying calendar and gallery update, to find out it makes double url titles again.

    Edited 3 times, last by Smooey ().

  • Back to those old style double names again, domain.com/gallery/gallery/, domain.com/blog/blog/, domain.com/calendar/calendar/ etc. It's fair to assume that calendar and gallery updates will do this same crap again, so I'd rather just save the money and not buy those two updates in future. No point in buying calendar and gallery update, to find out it makes double url titles again.

    Yeah... I know what you mean.
    Not sure how to remove these... Maybe with proper rewrite rules?!
    @Marcel Werk

  • yeah, it must be either htaccess rewrite rules or intentional, to handle the user's blog part of upgrade. I haven't tested this yet on fresh installation of 4.1 and 2.1 blog, I just installed the 2.1 blog into already existing 4.1 installation. maybe it's upgrade bug or something, or just intentional and just needs updated rewrite rules for htaccess.


    Another thing is all the 2.0 categories don't show up either, and they all have permissions for the groups to see and what-not. So those should be showing up as well, but are not. Although I haven't went through usergroup permissions under usergroups either, maybe I'm missing some permissions that need setting.


    Edit: I think it's best to consider it 27.xx money loss, live without the new features, and rebuild the entire site from ground up again (sigh) and just use 2.0 Blogs again. It easier than trying to make adjustments to it to get rid of the double name bullshit again sigh.

    Edited 4 times, last by Smooey ().

  • I did not have this problem and I upgraded from Woltlab Blog 2.0 to 2.1. I was using the blog as the homepage (main application). :love: Woltlab Blogs worked for me without any of the issues you're describing. :)


    Perhaps you have an add-on conflicting? :?:


    If you need support for this, it may be a good idea to post this in the support forum where it can get the appropriate attention or you could also open a ticket with support. ;)

  • thanks for deciding how i'll get helped and where to post about issues.. i didn't know this before.. Lol. :D i'll just wait for staff to reply, if need be, they can move posts into thread in support section. not sure if addons would be issue, but never know. i'll have to do further testing tomorrow.

  • Perhaps you have an add-on conflicting?

    Definitely not that. It's happening to various users, and was also tested on a fresh wbb 4.1 install with nothing else in it, but blog 2.0. Before we report it as a bug, and cry "wolf," let's see if we are overlooking something simple and/or if we can come up with a fix for it.

  • Deleted last post cause I was off a little on what happened when testing... Here's what happened in order.


    Stupid me, evidently tried updating localhost 4.1.5 and live site 4.1.5 to blog 2.1.0 from ACP by searching "com.woltlab.blog", which must have been setup package, not update package. It asked directory to install it in. So I ended up with urls like "domain.com/journals/blog/"



    Then, I made another new directory on localhost, did fresh 4.1.5 installation, did 2.0.11 blog installation into it. Was fine; localhost/blog/ THEN, updated with 2.1.0 blog update package, then url becomes localhost/blog/blog/ with pretty urls. Categories for blog didn't appear on index of blog page either nor right sidebar. Even with permissions for each usergroup set properly.



    Lastly, I did fresh 4.1.5 install in brand new directory, brand new database, and installed fine. Installed fresh 2.1.0 blog from acp "com.woltlab.blog", made directory "blog" and then url is localhost/blog/blog/ again sigh.. Thought the whole double name urls were gotten rid of in 4.1 / 2.1? The blog categories shows up in right sidebar on blog index doing this though, but still not appearing on blog index main page like they did / do with blog 2.0?



    Something just weird with all this lol. I'm not sure if this upgrade issues/bugs, blog bugs, controller issues, etc. I just hate the double worded titles in urls and thought / assumed they were gone from 4.1./2.1 series.. now they back again apparently with 2.1 user blogs.


    Definitely not that. It's happening to various users, and was also tested on a fresh wbb 4.1 install with nothing else in it, but blog 2.0. Before we report it as a bug, and cry "wolf," let's see if we are overlooking something simple and/or if we can come up with a fix for it.

    Yeah, alex did a fix for it.. xD It also fixed the Viecode Marketplace and Lexicon double word url issue. domain.com/marketplace/marketplace/ is now domain.com/marketplace/ :) and domain.com/lexicon/ Now just might spend more money on calendar and gallery updates like originally planned. lol :) :D ;) haha



    Copy raw file code and replace current one in installation.. lib/system/request/FlexibleRoute.class.php


    Code
    https://raw.githubusercontent.com/WoltLab/WCF/e2f01f06da8de5ba036cdaadf177b778565d69cc/wcfsetup/install/files/lib/system/request/FlexibleRoute.class.php

    Posts 10 to 20 could be moved to bugs forum probably. The ones about features regarding the blog 2.1.0 should stay here though.

    Edited once, last by Smooey ().

  • Yeah, alex did a fix for it.. xD It also fixed the Viecode Marketplace and Lexicon double word url issue. domain.com/marketplace/marketplace/ is now domain.com/marketplace/ and domain.com/lexicon/ Now just might spend more money on calendar and gallery updates like originally planned. lol haha

    Thank you for your persistency ;)
    It worked and it looks so much better now!!!


    big thanks to Alexander for fixing it !!

  • Thank you for your persistency ;) It worked and it looks so much better now!!!


    big thanks to Alexander for fixing it !!

    No problem. :) The only other thing I'm not sure about though, is why the blog categories aren't displaying on blog index page like before, or even in right hand sidebar. On test install, after installing 4.1.5 fresh and 2.1.0 blog fresh, it at least displayed the default category for blog in right hand sidebar on blog index page. I didn't mess with the permission settings for it either. Alex knows about that too, but maybe it's intentional and displays once articles are written to them, or maybe another bug? I'm not sure...

  • Maybe its not the right thread for it ?;)
    Open one in help and we continue to talk about it, ok?

    yeah i already mentioned it to alex about moving the posts in convo, he must be busy with other things lol. I suppose I could report the first "off topic" post in here and have another staff move it all.

  • Yeah, alex did a fix for it.. xD It also fixed the Viecode Marketplace and Lexicon double word url issue. domain.com/marketplace/marketplace/ is now domain.com/marketplace/ and domain.com/lexicon/ Now just might spend more money on calendar and gallery updates like originally planned. lol haha

    Nice one, Smooey. Of course, my thanks are also extended to Alex for making the fix. One less problem we will cry about :rolleyes:


    I'm glad this fixed urls with those other apps for you. I remember that you were struggling with it as well. Today is a good day to install blog and some apps ;)

    • Official Post

    Please bear in mind that this fix hasn't been extensively tested, I only tried it locally and here on woltlab.com. Please let me know if there any issues with it.

    Alexander Ebert
    Senior Developer WoltLab® GmbH