Your session expired, please login again.


  • This is going to drive me insane. Please have another look into this.

    Files

    • Official Post

    I've seen your IP address rotating in a quick manner, sometimes three different ones within 15 minutes, each originating from the same ip pool. This is an issue because the system can no longer recognize your session due to a mismatch with the stored data, rejecting the data provided by the browser.


    Reloading fixes the problem, as your browser will transmit the auth cookie again that is used to transparently log you in. AJAX requests are designed to ignore the auth cookie, which causes them to always reject your request on mismatch, no matter what else is provided (XSRF protection).

  • I've seen your IP address rotating in a quick manner, sometimes three different ones within 15 minutes, each originating from the same ip pool. This is an issue because the system can no longer recognize your session due to a mismatch with the stored data, rejecting the data provided by the browser.


    Reloading fixes the problem, as your browser will transmit the auth cookie again that is used to transparently log you in. AJAX requests are designed to ignore the auth cookie, which causes them to always reject your request on mismatch, no matter what else is provided (XSRF protection).

    * sigh * -- I think you're deferring and avoiding a yet to be resolved underline issue. While it is true, I have been jumping through public wifi, this error happens even when I'm not moving and on the same IP. I predict upon release, this is going to affect other people and you'll still be forced to look into this later. It would be better if you do so before release.

  • ^ A quick follow up after giving it more thought


    If a simple IP change causes this, you're going to annoy the hell out of mobile web users. That said, I still receive this error even on the same IP address (as previously stated).

  • It has already been fixed yesterday, but the changes are a bit more complex, so I haven't applied them manually yet. However it does work properly with RC 1.

    I look forward to verifying these changes once applied. Thank you :)

  • Abuse_and_Troll_Test how about your own installation? are you having the same session expired experience?

    Yes on my server, on the servers of few other folks here, and even on localhost which is why I suspect this is not something that can be ignored.


    WoltLab claims this has been addressed on RC1 so we'll have to wait and see.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!