Fehler beim Installieren

  • Hallo wenn ich das forum instalieren will und den pfad im browser eingebe kommt immer die abfrage ob ich die install.phb runterladen will und das kann ich auch tun sonst passiert nichts.


    Das kommt bei der test.php


    Support for PHP is missing.
    PHP Unterstützung nicht gefunden

    <!--
    */


    // check php version
    // php version
    $phpVersion = phpversion();
    $comparePhpVersion = preg_replace('/^(\d+\.\d+\.\d+).*$/', '\\1', $phpVersion);
    if (!(version_compare($comparePhpVersion, '5.0.5') >=
    0)) { ?>
    Your PHP version '<?php echo $phpVersion; ?>' is insufficient for
    installation of this software. PHP version 5.0.5 or greater is required.
    Ihre
    PHP Version '<?php echo $phpVersion; ?>' ist unzureichend für die Installation
    dieser Software. PHP Version 5.0.5 oder höher wird benötigt.
    <?php
    }


    // check ze1_compatibility_mode
    else if (ini_get('zend.ze1_compatibility_mode')) {
    ?>
    The option 'zend.ze1_compatibility_mode' is enabled. Please disable the
    option in your PHP configuration (php.ini) for a stable work of this
    software.
    Die Einstellung 'zend.ze1_compatibility_mode' ist aktiv. Für einen
    einwandfreien Betrieb dieser Software muss die Einstellung in der
    PHP-Konfiguration (php.ini) deaktiviert werden.
    <?php
    }


    // check simplexml
    else if (!function_exists('simplexml_load_file')) {
    ?>
    The 'simplexml' PHP extension is missing. Simplexml is required for a stable
    work of this software.
    Die 'simplexml' Erweiterung für PHP wurde nicht
    gefunden. Diese Erweiterung ist für den Betrieb der Software notwendig.
    <?php
    }


    //
    else {
    ?>
    PHP5 or greater is available. You can start the
    installation now.
    PHP5 oder höher wurde gefunden. Sie können mit der
    Installation beginnen.
    <?php
    }
    ?><!--EndFragment-->
    = 0)) { ?>


    Your PHP version '<?php echo $phpVersion; ?>' is insufficient for installation of this software. PHP version 5.0.5 or greater is required.
    Ihre PHP Version '<?php echo $phpVersion; ?>' ist unzureichend für die Installation dieser Software. PHP Version 5.0.5 oder höher wird benötigt.
    <?php
    }


    // check ze1_compatibility_mode
    else if (ini_get('zend.ze1_compatibility_mode')) {
    ?>
    The option 'zend.ze1_compatibility_mode' is enabled. Please disable the option in your PHP configuration (php.ini) for a stable work of this software.
    Die Einstellung 'zend.ze1_compatibility_mode' ist aktiv. Für einen einwandfreien Betrieb dieser Software muss die Einstellung in der PHP-Konfiguration (php.ini) deaktiviert werden.
    <?php
    }


    // check simplexml
    else if (!function_exists('simplexml_load_file')) {
    ?>
    The 'simplexml' PHP extension is missing. Simplexml is required for a stable work of this software.
    Die 'simplexml' Erweiterung für PHP wurde nicht gefunden. Diese Erweiterung ist für den Betrieb der Software notwendig.
    <?php
    }


    //
    else {
    ?>
    PHP5 or greater is available. You can start the installation now.
    PHP5 oder höher wurde gefunden. Sie können mit der Installation beginnen


    Mein system:


    WinXP Professional 5.1 Service Pack 2 (Build #2600)
    CPU: AMD Athlon 64 X2 Dual Core 4200+ / 2.21 GHz / 512 KB RAM: 1024 MB
    grafikkarte: 10nVidia GeForce 7600 GS


    Würde mich sehr freuen wenn mir jemand helfen könnte



    Gruß

  • Das bedeutet, dass dein Webspace kein PHP unterstützt.

    Quote

    Systemvoraussetzungen

    • PHP Version: 5.0.5
    • MySQL Version: 4.1.2
    • Freier Festplattenspeicher: 6 MB
  • Hallo aber ich kenne mich ehrlichgesagt garnicht mit dem PHP aus ich muss also die neuste version davon laden und dann geht es oder brauche ich noch was dazu im moment nutze ich den Filezilla FTB Webserver...

  • Genau der gleiche Fehler tritt bei der Installation unter 1und1 auf. PHP 5.0 ist im Webpaket enthalten. Allerdings läuft dort auch PHP3 und PHP4 gleichzeitig mit. Es gab zunächst einen Fehler mit der PHP-Version, den ich nun mittels htaccess - Datei scheinbar gelöst habe. Als Ergebnis kommt dann das oben beschriebene.


    Voraussetzungen vorher abgeklärt, Webpaket extra erweitert - trotzdem läufts nicht. Hoffentlich noch nicht.
    Ich kenne mich mit php auch nicht aus, vermute aber, dass ich eine php.ini anlegen muss und dort Einstellungen vornehmen - ähnlich wie bei der htaccess. Die Hotline von 1und1 nimmt sich von nix was an. Für den Fall, dass andere auch diese Probleme bekommen - die sagen, sie seien nicht zuständig.


    Edit: 17.56 Uhr:
    In den FAQ endlich gefunden:


    Wie kann ich .php Dateien als PHP5 parsen lassen?



    Sie können beliebige Dateitypen als PHP5-Skripte parsen ("ausführen") lassen. Häufig besteht der Wunsch alle .php-Dateien als PHP5-Skripte auszuführen.


    Legen Sie dazu eine .htaccess-Datei ins Stammverzeichnis Ihrer Präsenz und tragen Sie folgendes ein (bzw. fügen Sie es einer bereits existierenden .htaccess-Datei hinzu):


    Script 1: .htaccess AddType x-mapp-php5 .php


    ________________________________________________
    somit wurde die Installation gestartet. Hängt aber nun an der Datenbank, die scheinbar wieder auf php 4 zurückgreift... (wie praktisch)...
    _______________________________________________


    Insufficient MySQL version '4.0.27-standard-log'. MySQL 4.1.2 or greater is needed.


    ...das wars dann wohl... tschüss wbb3... bis später. :S


    ________________________________________________________
    Edit 19.23


    ...nach weiterem Lesen der FAQs: Datenbank gelöscht und mit MySQL 5.0 neu angelegt. Danach lief die Installation problemlos durch. Und das nach mehreren Stunden "Lesepause". EIN gescheiter Berater bei 1und1 hätte das abkürzen können auf ca. 30 min. Leider hatte ich heute nicht den "Richtigen" am Draht. Beide kannten nicht mal die eigenen FAQs.
    Nach etlichem hin- und her- suchen und klicken findet man doch die Lösung. Sehr unkomfortabel dort, aber machbar.

    Edited 3 times, last by Filas ().

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!