EA setzt options.inc.php nicht korrekt

    • WCF 1.1.x

      EA setzt options.inc.php nicht korrekt

      Huhu liebe Entwickler,

      ich arbeite seit kurzem an meiner eigenen EA und habe mir einen dementsprechende EA mit den ersten Optionen aufgebaut, welche man unter:

      github.com/DeltaNet-Production…roduction.ea.lizenzserver

      Einsehen kann. Kurz zu dem repo "commercial"; dort werden nur tele des Codes zu sehen sein, sollte ich mal Probleme haben.

      So weit so gut dachte ich mir und hab die EA installiert und musste feststelle, dass die EA die options.inc.php im WCF_DIR abgelegt wird und die Optionen beim änern nicht neugeschrieben werden.
      Normalerweise st jedoch die Datei in dem "EA"_DIR drinn, was mich verwundert, warum es bei mir nicht so ist.

      Darum wollte ich gern einmal wissen, wer von Euch dieses Problem schon einml gehabt hatte und wo mein Fehler liegt, da es ja kein normales Verhalten einer EA oder des WCFs ist.

      Für jede Hilfe bin ich sehr dankbar.
      Gruß

      Marcel
      -------------------------------------------
      Meine HP: DeltaNet Production

      Derzeit in Programmierung:
      • nichts
      Aktuelle Aktivitäten:
      • Neugestaltung der eigenen Webseite
      Du solltest keine TAR-files mit einchecken ;)
      Insbesondere das was du so im requirements-Ordner rumfliegt gehört eigentlich nich tin ein Repo eingecheckt.

      Dann solltest du Optionen englisch benennen. Insbesondere dieser deutsch englisch mix wie bei lizenzserver_admin_canSee_licenses_advanced ist doch ziemlich befremdlich. Entweder komplett deutsch oder - vorzugsweise - komplett englisch.


      Hast du das ganze in einer frischen WCF-Installation ausgetestet, oder in einer, die möglicherweise durch frühere Installationsversuche kompromittiert ist?
      Den oberen Teil packe ich mal ins OT rein ;).

      Ja, ist mir bewusst, dass der Lizenzserver momentan den deutsch/englisch Mix hat, bei einer späteren Mietversion aber sogesehen egal, da es ja nicht verkauft wird.
      Was die TARs angeht - nun ja, sind halt nun einmal mit drinn, da es mein einziges workingdirectory auf dem PC ist und ich somit diese nicht einfach mal entfernen kann.
      Wie sonst soll ich später dann das TAR packen ohne Requ's?

      Jip, habe esin einem reinem WCF getestet, in einem WCF mit WBBLite und in einem WCF mit WBB 3.1.6, jedes mal packt der die options.inc.php jedoch in den WCF_DIR.
      Sogar frisch und nicht per Update, darum nerft es mich ja so sehr, momentan.

      Es gibt halt eben keinen anständigen EA_Dummy, den man dafür nutzen könnte - leider :(.
      Gruß

      Marcel
      -------------------------------------------
      Meine HP: DeltaNet Production

      Derzeit in Programmierung:
      • nichts
      Aktuelle Aktivitäten:
      • Neugestaltung der eigenen Webseite

      Marcel Petzold wrote:

      Was die TARs angeht - nun ja, sind halt nun einmal mit drinn, da es mein einziges workingdirectory auf dem PC ist und ich somit diese nicht einfach mal entfernen kann.

      Du kannst sie auf deinem PC in dem Directory haben. Du solltest sie nur nicht commiten. Entweder schließt du .tar über die .gitignore aus, dann geht das automatisch, oder aber du achtest darauf, dass du die tars nicht dem commit hinzufügt. geht recht simpel.

      Die requirements kannst du doch wo ganz anders liegen haben, und von wo ganz anders holen, um sie mit einzupacken. Oder aber du hast sie in deiner lokalen Kopie dort, aber auch dann solltest du sie nich ins repo mit committen.


      Was passiert denn, wenn du das ganze ohne WBBLite 2/ WBB3 packst (also mit install.php und WCFSetup.tar.gz)?

      Btw, zeile 41 in deinem ACP hat nen Tippfehler: throw new PermissinDeniedException();, da fehlt nen o.
      Danke für den Hinweis mit dem "o".

      Wenn du mir sagst, wo ich die tar's in der .gitignore hinzufügen muss über die Git GUI oder über Git Bash, dann wäre ich schlauer und auch sehr dankbar dafür ^^, denn ich bin froh,
      dass ich den ganzen Krams bei GitHub zum laufen gebracht habe ^^.

      EDIT: So, EA funzt nun ohne Probleme. Ich weiß zwar nicht, wie der Fehler sich behoben hat, jedoch liegt die datei dort, wo sie liegen soll.
      Nun muss ich nur noch github einstellen ;).

      EDIT 2: Github erfolgreich eingestellt, damit weder Bilder, noch Archive oder andere, wichtige Dateien hinzugefügt werden (like *.sql oder install.php).
      Gruß

      Marcel
      -------------------------------------------
      Meine HP: DeltaNet Production

      Derzeit in Programmierung:
      • nichts
      Aktuelle Aktivitäten:
      • Neugestaltung der eigenen Webseite

      Post was edited 2 times, last by “Marcel Petzold” ().