Template/Compiled -Use of undefined constant

    Template/Compiled -Use of undefined constant

    So,

    Bevor wir jetzt auf ein "Benutz die SuFu" stoßen mal zu Beginn erläutert, dass ich etwas derartiges nicht gefunden hatte.
    Vor einigen Wochen hatte ich ein Plugin namens Additional Footer erstellt. Dieses gewährt dann die Funktion Links im Footer einfach zu gestalten und einzufügen.
    Beim deinstallieren bemerkte ich, dass es zu einem Fehler kommt. Ich hatte nochmals in einem Test Forum das Plugin allein getestet und gemerkt, dass es eig. nicht von dem Plugin kommen kann, dass so ein Fehler auftritt. So kam ich also hierher, nachdem ich mit vielen Möglichkeiten versucht hatte den Fehler zu beseitigen.
    Zu Beginn einmal die vollständige Fehlermeldung:

    Source Code

    1. Fatal error: PHP notice in file /www/htdocs/bsp/forum/wcf/templates/compiled/48_33_2_footer.php (20): Use of undefined constant MODULE_ADDITIONALFOOTER - assumed 'MODULE_ADDITIONALFOOTER'
    2. Information:
    3. error message: PHP notice in file /www/htdocs/bsp/forum/wcf/templates/compiled/48_33_2_footer.php (20): Use of undefined constant MODULE_ADDITIONALFOOTER - assumed 'MODULE_ADDITIONALFOOTER'
    4. error code: 0
    5. file: /www/htdocs/bsp/forum/wcf/lib/system/WCF.class.php (281)
    6. php version: 5.2.12-nmm2
    7. wcf version: 1.1.8 (Tempest)
    8. date: Tue, 10 Apr 2012 12:36:57 +0000
    9. request: /index.html
    10. referer: http://www.n-battle.net/board99-team-zentrale/board100-ank%C3%BCndigungssaal/1593-wichtig-neue-bereiche-im-n-battle-net/
    11. Stacktrace:
    12. #0 /www/htdocs/bsp/forum/wcf/templates/compiled/48_33_2_footer.php(20): WCF::handleError(8, 'Use of undefine...', '/www/htdocs/w00...', 20, Array)
    13. #1 /www/htdocs/bsp/forum/wcf/lib/system/template/Template.class.php(267): include('/www/htdocs/w00...')
    14. #2 /www/htdocs/bsp/forum/wcf/lib/system/template/Template.class.php(436): Template->display('footer', false)
    15. #3 /www/htdocs/bsp/forum/wcf/templates/compiled/48_33_2_index.php(151): Template->includeTemplate('footer', Array, 0)
    16. #4 /www/htdocs/bsp/forum/wcf/lib/system/template/Template.class.php(267): include('/www/htdocs/w00...')
    17. #5 /www/htdocs/bsp/forum/wcf/lib/page/AbstractPage.class.php(100): Template->display('index')
    18. #6 /www/htdocs/bsp/forum/wcf/lib/page/AbstractPage.class.php(46): AbstractPage->show()
    19. #7 /www/htdocs/bsp/forum/wcf/lib/util/RequestHandler.class.php(64): AbstractPage->__construct()
    20. #8 /www/htdocs/bsp/forum/wcf/lib/util/RequestHandler.class.php(92): RequestHandler->__construct('Index', Array, 'page')
    21. #9 /www/htdocs/bsp/forum/index.php(8): RequestHandler::handle(Array)
    22. #10 {main}


    Was ich bereits unternommen hatte war:
    options.inc.php gelöscht und nochmals regenerieren lassen
    Cache geleert.
    und mein Plugin, Additional Footer nochmals installiert und deinstalliert.

    Descole wrote:

    Cache geleert.

    Auch wcf/templates/compiled? Der Fehler sieht danach aus, als würde in der Datei 48_33_2_footer.php noch das Relikt der nicht mehr vorhandenen Konstante rumgeistern. Einfach den Ordner auch leeren.

    Edit: Da war jemand schneller xD
    98% aller PC Probleme sitzen direkt davor.

    - Linux/Debian (7.1 x64) vServer (KVM)
    - Apache 2.2.22
    - PHP 5.4 (5.4.4-14+deb7u4), php5-fpm / MySQL 5.5.31

    Ein paar Designs ...
    Btw. was ich gerade merke. Allgemein der Foot verändert sich bei mir nicht mehr. (Aktualisiert). Den Copyright den ich jetzt drinnen habe, hatte ich gestrig entfernt.. Hat vllt doch jemand mit diesem Ansatz eine Idee worans liegen könnte <.<?

    /Edit: Der Template Compiled Cache (footer halt :3) regeneriert sich bisherig immeriweder "gleich". Es verändert sich nicht.

    TimWolla hatte mich in einem anderen Forum angefragt, ob ich den Footer gepatched hatte,

    Ja hatte ich D:

    Difference-File

    1. --- C:/Plugins/AdditionalFooter/footer.tpl Tue Mar 20 20:32:51 2012
    2. +++ C:/Plugins/AdditionalFooter/footer_patched.tpl Tue Mar 20 20:51:30 2012
    3. @@ -2,6 +2,7 @@
    4. </div>
    5. <div id="footerContainer">
    6. <div id="footer">
    7. + {if MODULE_ADDITIONALFOOTER}{include file=additionalFooter}{/if}
    8. {include file=footerMenu}
    9. <div id="footerOptions" class="footerOptions">
    10. <div class="footerOptionsInner">

    Post was edited 2 times, last by “Descole” ().

    Der Punkt ist halt, wenn ich dich jetzt richtig verstanden habe, dass der Patch erfolgreich deinstalliert und entfernt ist, aber der Cache vom Footer sich nicht erneuert, bzw. nach einem Löschen generiert er den gleich wieder.

    In den Templates im ACP ist der Patch nicht mehr vorhanden so auch wenn man per FTP im wbb/templates/ schaut.

    /EDIT: Hat sich erledigt, hatte grade eben kurz bei cls-design nachgeschaut (in diesem Tutorial ) . Hatte Templatepatch manuell entfernt.
    Anscheinend wurde der Templatepatch bei der Datenbank nicht entfernt worden (bei der Deinstallation)