Fehlermeldung nach "Serverumzug"

    Fehlermeldung nach "Serverumzug"

    Hallo,

    wir nutzen seit einiger Zeit das BB 2.3.2. Nun ist unser Provider auf neue Server umgezogen und seitdem haben wir folgende Fehlermeldungen im oberen Bereich des Forum:



    • Wenn ein Thema aufgerufen wird:
      Deprecated: Assigning the return value of new by reference is deprecated in /var/www/virtual/*****.de/htdocs/e23for/thread.php on line 413
      Deprecated: Assigning the return value of new by reference is deprecated in /var/www/virtual/*****.de/htdocs/e23for/thread.php on line 819
      Deprecated: Assigning the return value of new by reference is deprecated in /var/www/virtual/*****.de/htdocs/e23for/thread.php on line 820
    • Wenn das eigene ControlPanel aufgerufen wird:
      Deprecated: Assigning the return value of new by reference is deprecated in /var/www/virtual/*****.de/htdocs/e23for/usercp.php on line 369
      Deprecated: Assigning the return value of new by reference is deprecated in /var/www/virtual/*****.de/htdocs/e23for/usercp.php on line 401

    • Wenn ich einen neuen Beitrag schreiben will:
      Deprecated: Assigning the return value of new by reference is deprecated in /var/www/virtual/*****.de/htdocs/e23for/pms.php on line 500
      Deprecated: Assigning the return value of new by reference is deprecated in /var/www/virtual/*****.de/htdocs/e23for/pms.php on line 634
      Deprecated: Assigning the return value of new by reference is deprecated in /var/www/virtual/*****.de/htdocs/e23for/pms.php on line 893
      Deprecated: Assigning the return value of new by reference is deprecated in /var/www/virtual/*****.de/htdocs/e23for/pms.php on line 914
      Deprecated: Assigning the return value of new by reference is deprecated in /var/www/virtual/*****.de/htdocs/e23for/pms.php on line 962
      Deprecated: Assigning the return value of new by reference is deprecated in /var/www/virtual/*****.de/htdocs/e23for/pms.php on line 1235
      Deprecated: Assigning the return value of new by reference is deprecated in /var/www/virtual/*****.de/htdocs/e23for/pms.php on line 1311

    usw...

    Immer bezieht sich diese Meldung auf "value of new...". Nachdem ich in diesem Forum bereits gesucht und folgenden Hinweis ausprobiert hatte:

    Das eigentliche Problem sollte behebbar sein, indem man einfach in den beiden Dateien nach:

    PHP-Quelltext
    & new

    sucht und es durch

    PHP-Quelltext
    new

    ersetzt. Wie so oft haben kleine Ursachen große Auswirkungen.

    ist es schonmal auf der Startseite des Forums (index.php) und der board.php-Seite besser geworden. In den anderen Bereichen/ auf den anderen Seiten bleibt die Fehlermeldung aber bestehen. Woran könnte das liegen?

    Vielen Dank im Voraus und schöne Grüße

    TobiasTM

    das 2.3 ist kein wbblite2 ;)

    das ist eine ältere wbb-version ...und ich nehme mal an, dass du dieses erst php5-fähig machen musst ...

    schau mal hier: speedyservice.de/2010/12/wbb-2-3-x-und-php-5-3/

    ansonsten gibts hier leider kein support mehr, für die älteren versionen...aber ich kann v-gn.de/wbb wärmstens empfehlen, die halfen mir mit meinem wbb2 schon immer super :)

    zudem solltest du zusehen, dass du dein 2.3.2 auf 2.3.6pl2 updatest, damit wenigst die bekanntesten Sicherheitslücken weg sind :) da gabs nämlich danach noch einige changelogs :)
    Mit freundlichen Grüßen
    von Bibi
    aus dem Name-my-Gif
    ...dein Forum für individuelle Namensgifs :thumbup:
    Hallo Bibi,

    vielen Dank für Deine Infos. Der Link ist (fast) schon Gold wert. Das war es nämlich. :)

    Was die Aktualität angeht... naja - ich habe eben einen Anruf von einer Bekannten bekommen mit dem Inhalt "Du der Hoster hat am Server was gemacht und jetzt kommen immer diese Fehlermeldungen... schau doch mal...". Und anschließend bin ich "mal eben" als Admin eingetragen und habe den Auftrag so schnell mal nebenbei alles zu richten, was der bisherige Admin hat liegen lassen (u. a. ein Update auf aktuelle Versionen)...
    Komisch, mein Board zickt aber nicht rum...keine ahnung, war bisher zu faul die ganzen dateien nochmal neu zu bearbeiten :whistling:
    aber zumindest auf 2.3.6pl2 hab ichs schon *g* :P
    hoff ihr habt noch alle dateien, sonst dürftet ihr ein problem haben, die downloads wurden hier aus den kundenbereichen entfernt, dann müsstest du höchstens an woltlab direkt mailen, ob die euch die nochmal geben :)

    wünsch dir viel erfolg ..freut mich, dass ich helfen konnte :)

    Edit: *rofl* ojee ....wie gesagt, weitergeben darf man die Daten leider nicht, da müsstest du dich mal direkt an [email protected] richten, ob die dir die sachen nochmal geben, weiss auch nicht, obs irgendwo die changelogs noch gibt ... ?(
    Mit freundlichen Grüßen
    von Bibi
    aus dem Name-my-Gif
    ...dein Forum für individuelle Namensgifs :thumbup: