SQL-Fehler im Cronjob

    SQL-Fehler im Cronjob

    Hallo,

    seid dem Server Umzug (zumindest ist seid dem Umzug das logging aktiv) bekomme ich reihenweise in den Log geschreiben. Es sind immer die 2 gleichen Fehler:

    Source Code

    1. PHP Fatal error: Uncaught exception 'DatabaseException' with message 'Invalid SQL: DELETE FROM wbb25292_1_user_last_post
    2. WHERE userID = 2
    3. ORDER BY time
    4. LIMIT 33' in ./wcf/lib/system/database/MySQLiDatabase.class.php:107
    5. Stack trace:
    6. #0 ./wcf/lib/system/database/Database.class.php(150): MySQLiDatabase->sendUnbufferedQuery('DELETE FROM wbb...')
    7. #1 ./wcf/lib/system/WCF.class.php(131): Database->sendShutdownUpdates()
    8. #2 [internal function]: WCF::destruct()
    9. #3 {main}
    10. thrown in ./wcf/lib/system/database/MySQLiDatabase.class.php on line 107


    Sowie:

    Source Code

    1. PHP Fatal error: Uncaught exception 'DatabaseException' with message 'Invalid SQL: UPDATE wcf25292_user user_table,
    2. wcf25292_session session
    3. SET user_table.lastActivityTime = session.lastActivityTime
    4. WHERE user_table.userID = session.userID
    5. AND session.userID <> 0' in ./wcf/lib/system/database/MySQLiDatabase.class.php:107
    6. Stack trace:
    7. #0 ./wcf/lib/system/database/Database.class.php(150): MySQLiDatabase->sendUnbufferedQuery('UPDATE wcf25292...')
    8. #1 ./wcf/lib/system/WCF.class.php(131): Database->sendShutdownUpdates()
    9. #2 [internal function]: WCF::destruct()
    10. #3 {main}
    11. thrown in ./wcf/lib/system/database/MySQLiDatabase.class.php on line 107


    Die SQL Abfragen sind fehlerfrei, die können ohne Probleme via phpMyAdmin ausgeführt werden.

    Hier mein aktuelles System:

    Source Code

    1. Burning Board® Version 3.1.6 (Volcano)
    2. Installationsdatum Montag, 14. Februar 2011, 21:35
    3. Community Framework™ Version 1.1.8 (Tempest)
    4. Server
    5. Betriebssystem Linux
    6. Webserver nginx
    7. PHP Version 5.4.0-3~lucid+3
    8. Datenbank
    9. MySQL Version 5.5.20-1~ppa1~lucid


    Fehler betraten allerdings schon mit WBB 3.1.4 auf, sowie mit PHP 5.3.2, 5.3.6, 5.3.7, 5.3.8 (+ Suhosin), 5.3.9, 5.3.10 und 5.4.0 und MySQL Server 5.1 und 5.5

    Im Frontend selbst treten keine Fehler auf.

    Kann mir da jemand behilflich sein?
    Das Forum habe ich damals nicht installiert. Kann also dazu keine Angaben machen.

    Da ich nur über eine Lizenz verfüge, habe ich nur eine Instanz des Forum laufen.

    Welcher Cronjob den Fehler schmeißt kann ich nicht sagen. Die Fehlermeldung ist unzureichend, den der Query ist nicht invaild.

    An den Cronjobs selbst habe ich natürlich nichts abgeändert.

    Edit:

    1. Meldung: /lib/system/cronjob/CleanupCronjob.class.php (durchschnitt alle 30 Minuten)
    2. Meldung: /lib/system/cronjob/LastActivityCronjob.class.php
    Files

    Post was edited 1 time, last by “slaver7” ().