Plötzlich weiße Seite

  • 2.1.x

    Plötzlich weiße Seite

    Hallo,

    ich habe mir schon die verschiedensten Themen hier und auch außerhalb des Forums angesehen und studiert, aber nichts hat auf mein Problem zugetroffen.

    Ich habe plötzlich eine weiße Seite gesehen als ich das Forum aufrief, und seitdem ist sie nicht mehr weg zubekommen. Ich habe bereits das memory_limit auf 512MB angehoben. Die index.php-Datei erneuert und die Session-Daten aus der Datenbank gelöscht. Nichts hat das Problem lösen können.

    Jetzt brauche ich eure Hilfe. Es wäre wirklich toll, wenn ihr mir helfen könntet. Vorweg schon mal, vielen Dank!

    lg rapid10
    Hallo,

    entschuldige, aber um sich ein Bild zu machen ein paar Rückfragen:
    hast Du es mal mit einem anderen Browser probiert?
    Hast Du evtl. Werbung im Forum, die irgendwelchen "unsauberen" Code liefert?
    Und: wie ist denn der Link zum Forum?

    Grüße
    Uli
    Ich bekomme den HTTP-Fehler 500 - interner Serverfehler.
    Irgendwas muss doch an den Forumscripten verändert worden sein, von Dir oder evtl. von Unbefugten. Oder der Server selbst hat eine Misskonfiguration bekommen. Wenn Du einen Webspace benutzt, kontaktiere Deinen Hoster, der soll im Errorlog nachsehen was das sein kann. Wenn Du einen eigenen (v)-Server betreibst, werte selbst die Logs aus.

    Grüße
    Uli
    Nein, ich nutze einen vServer. Alle anderen Webseiten funktionieren. Nur das Forum eben nicht. Der Apache kann also nicht falsch konfiguriert sein. Ich bekomme eine HTTP-Fehlermeldung 500 nur im Chrome-Browser. Im Firefox und Safari bekomme ich eine weiße Seite.

    Was für eine Datei könnte denn da kaputt sein?

    Danke für deine Antworten!
    Ich war mit dem IE drauf. ;)

    Nun, vermutlich eine der PHP- oder HTML-Dateien, aus denen der Forums-Code besteht. Schau Dir mal via FTP-Programm die Dateien im Forumsverzeichnis durch, welche ein Änderungsdatum um den Zeitpunkt herum hat als der Fehler auftrat. Die wäre dann schonmal verdächtig.

    Wie schaut's mit einer halbwegs aktuellen Sicherung der Forumsdateien aus?
    Und das Error-Log des Servers könnte dennoch wertvolle Hinweise enthalten.

    Grüße
    Uli
    Sorry, aber um das nochmal aufzugreifen. Es passiert immer wieder, nur weiß ich jetzt, was für ein Problem vorliegt und wie ich es behebe. Der Fehler: die options.inc.php Datei wird einfach "abgeschnitten". Sprich, der letzte Teil der Datei fehlt. Habe den Verdacht, dass das passiert, wenn die Datei beschrieben wird.

    Ich nutze suPHP und kann daher die Rechte 777 nicht geben. Trotzdem gibt sich die Datei immer wieder von selbst diese Rechte. Kann das Problem daran liegen - an den Rechten der options.inc.php?

    Danke für eure Meinungen!
    Nein, da steht nichts. Wird nur über andere Skripte der WBB-Installation genörgelt. :D

    Source Code

    1. [Sun Jan 15 04:15:48 2012] [error] [client 66.249.71.38] PHP Notice: Use of undefined constant WCF_DIR - assumed 'WCF_DIR' in /var/www/web2/html/rpg-harrypotter/wcf/lib/acp/package/plugin/SmiliesPackageInstallationPlugin.class.php on line 3